Project

General

Profile

Problem with 5.2.0 Final Release start

Maciej Bursztynowski
Added almost 5 years ago

Hi,

I wanted to update my Tigase (5.2.0 beta2) to stable version,

I've made mysql and tigase folder backup. I've tried to overwrite old files(excluding init.properties and tigase.conf files) using tar.gz package, I've changed permissions to scripts/tigase.sh and tried to run tigase. Below is what I got:

@# ./scripts/tigase.sh run etc/tigase.conf

Running Tigase:

Exception in thread "main" java.lang.UnsupportedClassVersionError: tigase/server/XMPPServer : Unsupported major.minor version 51.0

    at java.lang.ClassLoader.defineClass1(Native Method)

    at java.lang.ClassLoader.defineClass(ClassLoader.java:634)

    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)

    at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)

    at java.net.URLClassLoader.access$000(URLClassLoader.java:73)

    at java.net.URLClassLoader$1.run(URLClassLoader.java:212)

    at java.security.AccessController.doPrivileged(Native Method)

    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)

    at java.lang.ClassLoader.loadClass(ClassLoader.java:321)

    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)

    at java.lang.ClassLoader.loadClass(ClassLoader.java:266)

Could not find the main class: tigase.server.XMPPServer. Program will exit.

@

I thought, that if I perform clean install from .jar file and fresh database it would help. I was wrong - there was the same error.

There is no other log files.

What could went wrong? What can I do?

Thanks in advance,

Maciek


Replies (3)

Added by Wojciech Kapcia TigaseTeam almost 5 years ago

As described in the release notes version 5.2.0 now requires JDK7 to run.

Added by Maciej Bursztynowski almost 5 years ago

Thanks,

I was pretty sure, that I have Java v7, but I didn't.

There is one more problem with this during start:

@2014-02-20 14:30:32.724 [main] ShortNewsPublisher.setParams() SEVERE: Problem initializing database connection.

java.sql.SQLException: Access denied for user 'root'@'127.0.0.1' (using password: YES)@

I think it is problem with new pubsub. I've never used it - but now I wanted to, so I imported mysql-pubsub-schema-3.0.0.sql, then I run pubsub-db-migrate.sh using my configuration:

@]# database/pubsub-db-migrate.sh -in 'jdbc:mysql://localhost/tigase?user=root&password=MYPASS' -out 'jdbc:mysql://localhost/tigase?user=root&password=MYPASS'

@

and it ended successfully (I think so), because script found databese, initialized connection, started migration, then migration finished.

Maybe you know where is my mistake ?

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam almost 5 years ago

Looks like DB misconfiguration or Tigase misconfiguration. The error says: Access denied for user 'root''127.0.0.1'. Make sure you have added the user to MySQL database and granted permissions to access the database.

Usually 'root' user is a super user in MySQL but not 'root@127.0.0.1'.

    (1-3/3)