Project

General

Profile

S2S Dialback issue

Pascal S
Added about 5 years ago

Hello

I am trying to implement an XMPP service using Tigase.

Currently I run tigase-server-5.2.0-b3447 and everything is running smoothly inside my own cluster.

My problem occurs whenever I try to interface my server with another XMPP existing one (trying to add a user register on this other server).

Using both my Tigase logs and the remote server logs I identified an issue in the dial-back exchange (very similar to https://projects.tigase.org/issues/1194) I know that this issue is due to be fixed in Tigase 5.2.1 but is their a configuration I can trigger to workaround this issue?

Unfortunately I can only modify my Tigase installation as the set up of the other server is fixed for compatibility purpose.

Thanks in advance.


Replies (14)

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam about 5 years ago

Maybe you could try our nightly builds? It should contain all the recent fixes.

Added by Pascal S about 5 years ago

I would definitely try your solution.

Where can I find your nightly build?

On https://projects.tigase.org/projects/tigase-server/files?sort=created_on%3Adesc%2Cfilename I've downloaded and installed what I think is the latest available build (tigase-server-5.2.0-b3447.jar).

Thanks in advance.

Added by Wojciech Kapcia TigaseTeam about 5 years ago

Nightlies are available on our build machine: http://build.tigase.org/nightlies/dists/

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam about 5 years ago

Heh, Wojciech was faster, with regards to the issue #1194, I talked to other team member who submitted the issue and it looks like this might be already solved as we can no longer replicate it. I think your problem might be related to something else, maybe DNS configuration? Please note, s2s connections are very sensitive to DNS config.

Added by Pascal S about 5 years ago

At first I though it was a DNS configuration issue (as everything else was working just fine).

Here are partial log on my receiving server side. tigase.example.com is running on tigase (obviously) and test.example.com is the legacy server I try to interact with.

18:33:02.547 5 XMPPO-000007(tigase.example.com) s-out: <db:verify from="test.example.com" to="tigase.example.com" id="1203">db976b7e52ca2e97a0666255d6718aa2b0afcfb3</db:verify>

18:33:02.561 5 XMPPO-000007(tigase.example.com) s-inp: <verify type="error" from="tigase.example.com" to="test.example.com" xmlns="jabber:server:dialback" id="1203"><error code="501" type="cancel"><feature-not-implemented xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/><text xmlns="urn:ietf:params:xml:ns:xmpp-stanzas" xml:lang="en">Feature not supported yet.</text></error></verify>

Added by Pascal S about 5 years ago

To be more precise this type of log occurs whenever I try to add a user register on test.example.fr to the roster of a user register on tigase.example.com

Added by Pascal S about 5 years ago

I tried and installed the last night build (tigase-server-5.3.0-SNAPSHOT-b3462) and still the same issue. No luck ;-).

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam about 5 years ago

From the log you provided it looks like the test.example.com attempts to connect to tigase.example.com on c2s connection (client port 5222). The server connection for tigase.example.com should be made on port 5269 (s2s port). If the server connects on a correct port 5269, then maybe the tigase.example.com is configured incorrectly and accepts clients connections on that port.

Added by Pascal S about 5 years ago

I'll look into this.

Is their a way to force the s2s port to a different one (for some reason I might not be able to use port 5269)?

I've put those line into my init.properties files trying to make the xxxx port the s2s port of my tigase setup:

--s2s-ports = xxxx

I imagine that using one port for both s2s and c2s is not a good idea. Thanks for your response.

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam about 5 years ago

Yes, the option above can be used to have s2s on a different than standard port. You just have to set SRV record in DNS correctly to point to a correct port.

Sharing a port between s2s and c2s is not supported at the moment.

Added by Pascal S about 5 years ago

Thanks for the help. I manage to work around this issue with your advices.

Added by Pascal S about 5 years ago

Can I ask one additional thing (related to my DNS issue), could you list the ports needed for Tigase to work fine (including clustering and other available plugins)?

Added by Wojciech Kapcia TigaseTeam about 5 years ago

Those are mainly regular ports and mostly depends on what you use:

  • 5222 - client connections

  • 5223 - legacy SSL connection port

  • 5280 - BOSH connection

  • 5269 - server-to-server connections

  • 5277 - clustering connections

  • 5290 - websocket connections

Monitoring ports are configured when enabling particular mechanism.

Added by Pascal S about 5 years ago

Thank for your help it seems to work just fine.

    (1-14/14)