Project

General

Profile

Error starting server after installation: TIGASE_HOME shall not be set

Julian R
Added about 5 years ago

Hi,

i just tried to install tigase on my new raspberry pi. But anyway i get stuck at the point of starting tigase via "./tigase.sh start etc/tigase.conf". It tells my everytime "TIGASE_HOME is not set. ...".

I've already tried some possible solutions but was not able to fix that problem.

I'm using tigase-server-5.2.0-b3447.jar and console-installer. OS: Raspbian

Hope you can help me :-)

Thanks and best regards

Julsky


Replies (2)

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam about 5 years ago

Apparently the Tigase's startup script cannot find Tigase binary files. If you installed Tigase using installer, then you should be able to start it using command:

./scripts/tigase.sh start etc/tigase.conf 

or:

./bin/tigase.sh start etc/tigase.conf 

Please see the directory from which you run the tigase startup script. The script tries to discover TIGASE_HOME.

If this still does not work you can try to set it manually:

TIGASE_HOME="/home/tigase/tigase-server" ./scripts/tigase.sh start etc/tigase.conf 

Added by Julian R about 5 years ago

Thank you very much. Just had been in the wrong directory.

Best regards

Julsky

    (1-2/2)