Project

General

Profile

Java sigfault after 65535 connections

Sean Drummond
Added over 4 years ago

Hey guys we are hitting a limit of 65,535 simultaneous users online. When tigase has ~65535 fds it sigfaults upon any new connection. The connection is opened and then immediately closed by host.

[root@app2 ~]# telnet <server> 5222
Trying 192.168.64.95...
Connected to <server>.
Escape character is '^]'.
Connection closed by foreign host.

We have double checked all of our server configuration settings and no limits are being hit. There is nothing in either log files and we have been unable to collect a core dump.

I have attached the strace. We have also used jstack on the tigase process and not collected anything useful. Let me know if there is anything you would like me to collect.


Replies (3)

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam over 4 years ago

Have you read our online guides for the OS settings:

  1. http://www.tigase.org/content/linux-settings-high-load-systems

  2. http://www.tigase.org/content/basic-system-checks

Please make sure you adjusted operating system settings accordingly for your service requirements.

On top of that we cannot help you too much as you provided too little information:

  1. What Tigase version do you use?

  2. What operating system do you use?

  3. What Java version and vendor do you use?

Added by Sean Drummond over 4 years ago

I have read and adjusted the OS settings according to http://www.tigase.org/content/linux-settings-high-load-systems.

1) tigase-server-5.2.1

2) Centos 6.3

3) java-1.7.0-openjdk-devel

I have also come across this; https://projects.tigase.org/projects/tigase-server/wiki/JVM_(Tigase)_crash

I feel we might be running into a similar problem.

Added by Sean Drummond over 4 years ago

Some of my tests may lead me to believe that the strace that I am running may be causing some of the faults. I was running java-1.7.0_40 I am starting to retest while using 1.7.0_55

    (1-3/3)