Project

General

Profile

MUC: MAX HISTORY FETCH SIZE seems to be 20 regardless of the configuration setting done during MUC create

Girish Prabhu
Added over 4 years ago

I am using SMACK API on the client side. I am creating a MUC chat room with form data where i set the muc#maxhistoryfetch to 101 (eg: submitForm.setAnswer("muc#maxhistoryfetch", "101"); I printed the submitted form and verified that it's getting set to 100 in the call.

Now, regardless of what value I set, I seem to only get 20 messages (from history) when a new user joins the MUC room. I checked the server settings..and there was no setting in the init.properties (not sure what the default value is), so I went ahead and made an entry in init.properties file

muc/muc-max-history-size[I]=100

despite this, I still see only 20 messages being sent to the user. What am i missing here?. Also, logging it set to on, where does the server log the muc messages?

FYI - my sent packets (see the 101 value for muc#maxhistoryfetch)

1

0

0

1

101

My init.properties settings are:-

muc/muc-max-history-size[I]=100

muc/component-id[S]=muc@gprabhu-mba.local

muc/def-hostname[S]=gprabhu-mba.local

muc/admins[s]=admin@gprabhu-mba.local

muc/scripts-dir[S]=scripts/admin

muc/command/ALL[S]=ADMIN

muc/max-queue-size[I]=466

muc/scheduler-threads[I]=1

muc/incoming-filters[S]=tigase.server.filters.PacketCounter

muc/outgoing-filters[S]=tigase.server.filters.PacketCounter

muc/message-filter-enabled[B]=true

muc/presence-filter-enabled[B]=false

muc/search-ghosts-every-minute[B]=false

muc/hostnames[s]=muc.gprabhu-mba.local

muc/history-db[S]=derby

muc/history-db-uri[S]=jdbc:derby:/Users/gprabhu/play/tigase-server/tigasedb

muc/room-log-directory[S]=./logs/

muc/muc-allow-chat-states[B]=false

muc/muc-lock-new-room[B]=true

muc/muc-multi-item-allowed[B]=true


Replies (2)

Avatar?id=6098&size=32x32

Added by Bartosz Małkowski TigaseTeam over 4 years ago

muc-max-history-size is +maximum+ history items you can +ask+!

If you enter to room with:

<presence
    from='hag66@shakespeare.lit/pda'
    id='n13mt3l'
    to='coven@chat.shakespeare.lit/thirdwitch'>
  <x xmlns='http://jabber.org/protocol/muc'>
    <history since='1970-01-01T00:00:00Z'/>
  </x>
</presence>

you will see up to 101 latest messages.

If you don't ask for history you will get 20 latest messages.

Added by Girish Prabhu over 4 years ago

Thanks for the response, but I am not sure how the <presence you pasted is connected to 101 messages...in other words, how do we configure max to 200, for instance.

-g

    (1-2/2)