Project

General

Profile

Installation issue

Prashanth Raghu
Added over 4 years ago

Hi

I am trying to setup Tigase on my local machine following the guide : https://projects.tigase.org/projects/tigase-server/wiki/Quickstart

I am using pidgin as well as Spark as my XMPP client.

Server Details:

  1. Domain : localhost

  2. Port : 5223

Username and password are of the default admin user.

The error displayed by the smack client logs:

WARNING: Exception in Login:
Connection failed. No response from server.: 
    at org.jivesoftware.smack.PacketReader.startup(PacketReader.java:119)
    at org.jivesoftware.smack.XMPPConnection.initConnection(XMPPConnection.java:568)
    at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection.java:527)
    at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:953)
    at org.jivesoftware.LoginDialog$LoginPanel.login(LoginDialog.java:1009)
    at org.jivesoftware.LoginDialog$LoginPanel.access$1200(LoginDialog.java:219)
    at org.jivesoftware.LoginDialog$LoginPanel$4.construct(LoginDialog.java:730)
    at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:141)
    at java.lang.Thread.run(Unknown Source)
java.io.EOFException: input contained no data
    at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:3003)
    at org.xmlpull.mxp1.MXParser.more(MXParser.java:3046)
    at org.xmlpull.mxp1.MXParser.parseProlog(MXParser.java:1410)
    at org.xmlpull.mxp1.MXParser.nextImpl(MXParser.java:1395)
    at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093)
    at org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:325)
    at org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:43)
    at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:70)
Oct 14, 2014 12:32:39 PM org.jivesoftware.spark.util.log.Log warning
WARNING: Exception in Login:
Connection failed. No response from server.: 
    at org.jivesoftware.smack.PacketReader.startup(PacketReader.java:119)
    at org.jivesoftware.smack.XMPPConnection.initConnection(XMPPConnection.java:568)
    at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection.java:527)
    at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:953)
    at org.jivesoftware.LoginDialog$LoginPanel.login(LoginDialog.java:1009)
    at org.jivesoftware.LoginDialog$LoginPanel.access$1200(LoginDialog.java:219)
    at org.jivesoftware.LoginDialog$LoginPanel$4.construct(LoginDialog.java:730)
    at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:141)
    at java.lang.Thread.run(Unknown Source)

I am however able to telnet to ports 5222, 5223.

Am I missing something here ?


Replies (15)

Added by Wojciech Kapcia TigaseTeam over 4 years ago

Given that you are able to connect using telnet then it's most likely issue with the smack library or usage therof. Please try connecting using regular client, like Psi or Pidgin. If everything is ok then the issue is related to smack library and further questions should be asked in their forums.

Added by Prashanth Raghu over 4 years ago

Thanks for the immediate reply Wojciech.

I also tried using Pidgin to connect to the server.

The description of errors from Pidgin are attached below.

Added by Prashanth Raghu over 4 years ago

I just started to use tclmt for debugging my server.

I have also attached the error message from tclmt.

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam over 4 years ago

Make sure the account admin@localhost is already a registered account on the Tigase server (so you can correctly login) and make also sure the account is listed as an admin account in the Tigase server init.properties file.

Added by Prashanth Raghu over 4 years ago

Hi Artur,

Thanks for the quick response.

I have already done that.

I also noticed that there were two pem files being generated in the certs folder:

  1. default.pem

  2. localhost.pem

Although I had only mentioned localhost as the domain.

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam over 4 years ago

I just looked at the attached pidgin files. It looks like you set Pidgin to connect to port 5223. This is SSL port but the Pidgin logs do not indicate any SSL/TLS handshaking. Try to configure Pidgin to connect to port 5222 instead or specify in Pidgin that port 5223 is legacy SSL.

Both pem files are generated automatically by Tigase. If an SSL certificate is missing Tigase automatically generates self-signed SSL certificate to allow secure connections. default.pem is for legacy SSL connections, localhost.pem is for all TLS connections for localhost domain.

Could you provide your init.properties file?

Added by Prashanth Raghu over 4 years ago

Hi Artur,

When I tried connecting to port 5222 through pidgin I am getting an "Not Authorized" error. ( Screenshot attached )

But when I see the tig_users database from the MySQL console I can see that the user entry is present in the table. ( Screenshot Attached )

I have also attached the init.properties file.

Added by Wojciech Kapcia TigaseTeam over 4 years ago

Can you look in either Pidgin logs or Tigase logs (@logs/@) for reason of not being authorized - it should be the last received stanza in Pidgin.

Added by Prashanth Raghu over 4 years ago

Hi Wojciech,

Here is the snapshot of the pidgin logs:

 <?xml version='1.0'?><stream:stream xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' from='localhost' id='83cc457a-984d-4ee6-abb2-f398dc641b2a' version='1.0' xml:lang='en'>
(10:33:10) jabber: Recv (ssl)(1): <
(10:33:10) jabber: Recv (ssl)(402): stream:features><ver xmlns="urn:xmpp:features:rosterver"/><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>PLAIN</mechanism><mechanism>ANONYMOUS</mechanism></mechanisms><register xmlns="http://jabber.org/features/iq-register"/><compression xmlns="http://jabber.org/features/compress"><method>zlib</method></compression><auth xmlns="http://jabber.org/features/iq-auth"/></stream:features>
(10:33:10) sasl: Mechs found: PLAIN ANONYMOUS
(10:33:10) jabber: Sending (ssl) (admin@localhost/pidgin): <auth xmlns='urn:ietf:params:xml:ns:xmpp-sasl' mechanism='PLAIN' xmlns:ga='http://www.google.com/talk/protocol/auth' ga:client-uses-full-bind-result='true'>password removed</auth>
(10:33:10) jabber: Recv (ssl)(1): <
(10:33:10) jabber: Recv (ssl)(124): failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized/><text xml:lang='en'>Password not verified</text></failure>
(10:33:10) sasl: Mechs found: ANONYMOUS
(10:33:10) sasl: No worthy mechs found
(10:33:10) connection: Connection error on 0x22f22658 (reason: 2 description: Not Authorized)
(10:33:10) account: Disconnecting account admin@localhost/pidgin (0x22a7a070)

Added by Wojciech Kapcia TigaseTeam over 4 years ago

Above would indicate that there is some problem with your installation/database configuration which prevents tigase to validate the password. Make sure (examine tigase logs) that the Authentication Repository was initialized correctly.

Added by Prashanth Raghu over 4 years ago

I am unable to find any Authentication Repository errors. I also tried using the default Derby Database to avoid any database errors.

Added by Wojciech Kapcia TigaseTeam over 4 years ago

Please share complete logs/tigase-console.log and logs/tigase.log.0 logs from clean startup after which the issue manifest itself. Please also modify etc/init.properties and have following debug settings enabled:

--debug=server,xmpp.impl,db

Added by Prashanth Raghu over 4 years ago

Hi Wojciech,

I have done that.

I have attached the following three files you have requested for.

I am currently using Sun JDK 7 to run tigase on.

Added by Wojciech Kapcia TigaseTeam over 4 years ago

How do you start Tigase? It looks like you are not passing config file as an argument hence Tigase uses default and completely ignores your configuration. You should use (under linux), from tigase home directory:

scripts/tigase.sh start etc/tigase.conf

Added by Prashanth Raghu over 4 years ago

Hi Wojciech,

Thanks a lot for your help.

I completely ignored adding the configuration file.

It works perfect now.

    (1-15/15)