Project

General

Profile

tigase 5.2.2 init.properties load fail

bao qf
Added about 4 years ago

I download tigase file is tigase-server-5.2.2-b3463-dist-max.tar.gz.

tar -zxvf files,cd tigase path,don't modify anything

And start tigase as : ./scripts/tigase.sh start ./etc/init.properties

std out is :

./etc/init.properties: line 1: config-type=--gen-config-def: command not found

./etc/init.properties: line 2: --admins=admin@: command not found

./etc/init.properties: line 3: --virt-hosts: command not found

./etc/init.properties: line 4: --debug=server: command not found

Starting Tigase:

Tigase running pid=10915

nohup: redirecting stderr to stdout

When replace init.properties file ,more command not found error.And tigase use default config.

What't wrong?


Replies (3)

Added by Wojciech Kapcia TigaseTeam about 4 years ago

when using tigase.sh you should provide path to tigase.conf file which provides bootstrap entries/configuration for java process, including

TIGASE_OPTIONS=" --property-file etc/init.properties "

which is the parameter used by Tigase to read properties.

Added by bao qf about 4 years ago

tigase.conf file exist TIGASE_OPTIONS=" --property-file etc/init.properties " .

But also load fail,in bash windows every row show: command not found.

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam about 4 years ago

Yes, Wojciech was not specific enough. Your command to start Tigase server is incorrect.

The correct way to start Tigase server is this:

./scripts/tigase.sh start etc/tigase.conf

    (1-3/3)