Project

General

Profile

Tigase HTTP component

praveen poojary
Added about 4 years ago

I am trying to load the HTTP component as mentioned in https://projects.tigase.org/projects/tigase-http-api/wiki/Configuration

I am seeing from the tigase logs the following error:

WARNING: Can't load component http: tigase.http.HttpMessageReceiver is external class.

I am unable to find out the reason for the following.

Thanks for your help,

Praveena


Replies (7)

Added by praveen raj about 4 years ago

I am also facing this issue.

Added by Wojciech Kapcia TigaseTeam about 4 years ago

praveen poojary wrote:

I am seeing from the tigase logs the following error:

WARNING: Can't load component http: tigase.http.HttpMessageReceiver is external class.

I am unable to find out the reason for the following.

Which Tigase version are you using and which bundle? Do you have all needed dependencies, including the component itself, in the jars/ directory?

Added by praveen poojary about 4 years ago

I am using Tigase version : 5.2.2-b3464t

Yes I have all the dependencies in the jar files which I have verified using scripts/tigase.sh check etc/tigase.conf

The list of the files to include for the component was obtained from https://projects.tigase.org/attachments/download/1006/tigase-http-api-libraries.tar.gz along with tigase-http-api.jar

Have I missed out something ?

Added by Wojciech Kapcia TigaseTeam about 4 years ago

praveen poojary wrote:

I am using Tigase version : 5.2.2-b3464t

But which package? Can you give the url that you used to download it?

Yes I have all the dependencies in the jar files which I have verified using scripts/tigase.sh check etc/tigase.conf

The list of the files to include for the component was obtained from https://projects.tigase.org/attachments/download/1006/tigase-http-api-libraries.tar.gz along with tigase-http-api.jar

Have I missed out something ?

If you are using packages from the download section then all needed dependencies are already included.

Added by praveen poojary about 4 years ago

The link I used to download the package : https://projects.tigase.org/attachments/download/1740/tigase-server-5.2.2-b3464.jar

Yes. I am using the packages from the download section. I just used the tigase-http-api-libraries to verify if all the jars were included.

Added by Wojciech Kapcia TigaseTeam about 4 years ago

Actually Tigase 5.2.2 bundles HTTP Api component version 1.0.0 and you tried configuration for version 1.1.0+. Please follow configuration steps for older version

Added by praveen poojary about 4 years ago

Thanks for the help. It now works fine.

    (1-7/7)