Project

General

Profile

Tigase Clustering error

praveen raj
Added about 4 years ago

Hi,

I am trying to setup my first Tigase cluster using two tigase nodes on the same network.

I have added --cluster-mode=True to enable clustering and have done nothing else in the configuration. "

I have noted that the cluster_nodes table in MySQL contains the hostname and password entries for the two nodes.

I have also setup the right DNS configuration through the /etc/hosts filename.

I have attached the configuration file and the console log.

I shall also attach the configuration file and console log from the other machine as a comment to this post.

Regards,

Raj


Replies (3)

Added by Wojciech Kapcia TigaseTeam about 4 years ago

As per error:

Remote hostname not found in local configuration or time difference between cluster nodes is too big.

Please make sure time on the machines is in sync.

Added by praveen raj about 4 years ago

Hi Wojciech,

Thanks for the reply. The time on the machines is in sync with a common NTP server through the internet.

I noticed that despite these errors the admin of the domain is getting a message stanza from the session manager indicating a successful connection in the cluster nodes.

Example:

<message xmlns='jabber:client'

     from='sess-man@tigase1.cloud.com'

     to='admin@tigase1.cloud.com'

     id='sess-man5'

     type='chat'>

Cluster node tigase1.cloud.com connected to tigase2.cloud.com (Thu Nov 20 15:47:30 IST 2014)

cluster_status_update

Can I consider this as a successful data connection ?

Regards,

Raj

Added by Wojciech Kapcia TigaseTeam about 4 years ago

You did not specify what kind of errors you receive. From the above message/stanza we can conclude that clustering is working.

    (1-3/3)