Project

General

Profile

Tigase installation error when MySQL database is specified

Peter Rajcani
Added about 4 years ago

I get the following error when I try to install Tigase 5.2.3 on our Linux machine:

Checking connection to the database

Connection OK

Checking if the database exists

Exists OK

Checking the database schema

Can't load schema: Specified key was too long; max key length is 767 bytes

Checking whether the database needs conversion

Something wrong, the schema still is not loaded...

Adding XMPP admin accounts

Database schema is invalid

Post installation actions

Database schema is invalid

Loading socks5 component schema

Loading socks5 schema...

Can't load socks5 schema: Specified key was too long; max key length is 767 bytes

Is this an issue with the MySQL database that we are using?


Replies (4)

Added by Peter Rajcani about 4 years ago

Found a post about the same issue:

https://projects.tigase.org/boards/15/topics/3244?r=3278#message-3278

I modified the my.cnf file as suggested:

innodb_large_prefix=true

innodb_file_format=barracuda

innodb_file_per_table=true

and restarted the MySQL database

The installation went through without errors. However, when I start the Tigase server, I get the following exception (see attached log file)

the add-user command fails:

./bin/tclmt.sh -u admin@tigasetest.com -p tigase add-user

Dec 24, 2014 3:37:21 PM tigase.xml.db.XMLDB setupNewDB

INFO: Create empty DB.

Exception during connection to tigasetest.com:

java.net.UnknownHostException: tigasetest.com

I hace specified the XMPP domain during installation as 'tigasetest,com'

Any idea what I am missing?

We had no issues adding users with the default database (Derby).

Added by Peter Rajcani about 4 years ago

Sorry, the first log file attached to my post is incorrect. I attached the correct one. I did not find a way to remove an attached file from the post. I also tried installing the latest version (7.0.0-SNAPSHOT) but I still get the error when I start the Tigase server. The installation does not report any errors. Log files for both (5.2.3 and 7.0.0) are attached

Added by Wojciech Kapcia TigaseTeam about 4 years ago

In both cases you have already running instance of Tigase therefore you most likely connect to some other/old one:

2014-12-24 15:33:37.642 [ConnectionOpenThread]  ConnectionOpenThread.addAllWaiting()  WARNING: Error: creating connection for: {type=accept, socket=plain, ifc=[Ljava.lang.String;@30799905, remote-host=localhost, required=false, port-no=5222}
java.net.BindException: Address already in use
    at sun.nio.ch.Net.bind0(Native Method)
    at sun.nio.ch.Net.bind(Net.java:444)
    at sun.nio.ch.Net.bind(Net.java:436)

Added by Peter Rajcani about 4 years ago

Thanks, we noticed the same issue and corrected the problem.

    (1-4/4)