Project

General

Profile

Unable to connect to tigase from Android phones

Prashanth Raghu
Added about 4 years ago

Hi,

I am facing a very strange issue with my Tigase installation. While the installation works perfectly with a non-mobile client ( client library(smack), pidgin and also websockets), I am unable to connect to the installation through a mobile device such as Android.

It's strange that I am also unable to telnet to the port from the mobile device, while it works perfectly fine from the desktop/ websocket clients.

Any help in this regard would be great.

Regards,

Prashanth


Replies (3)

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam about 4 years ago

What software do you use on your mobile device to connect to the XMPP Server? I mean XMPP software, not the telnet program. If you cannot even telnet to the server port, than it is most likely an issue with either your device configuration or your mobile network. Have you tried to connect to your XMPP server from mobile over WiFi?

have you tried our Tigase Android XMPP client?

Added by Prashanth Raghu about 4 years ago

Hi Arthur,

I am using the asmack client library to connect to the tigase instance from the android phone. I did try to connect to the instance through many number of networks :

  1. Wifi

  2. Data Networks(3G)

Yes I also tried the Android XMPP client of Tigase.

Regards,

Prashanth

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam about 4 years ago

Did the Tigase Messenger for Android work? Did any combination work for you?

However, if even telnet cannot connect, then I am afraid the problem has nothing to do with XMPP, if you cannot telnet even over wifi network, then it is most likely some configuration of your Android device or your Tigase instance is not exposed to the internet and you are trying to connect to it from the internet.

Did you try to connect to tigase.im installation - our public XMPP service?

We do use XMPP on our Android devices without any problem so it can work and it must be something with either your device settings or network configuration.

    (1-3/3)