Project

General

Profile

It's not possible to login with some xmpp clients - Tigase 7.0.0

Gianluca Lorenzin
Added almost 4 years ago

Hi,

I'm not able to login with clients like Jitsi or Spark, instead using Psi or Smack library API login succeed; Tigase version is 7.0.0.

Could be a problem regarding TLS or certificates?

Can you help me? Thanks in advance


Replies (6)

Added by Gianluca Lorenzin almost 4 years ago

If it could be useful the error is: "XMPPException: SASL authentication PLAIN failed: text".

Added by Wojciech Kapcia TigaseTeam almost 4 years ago

Related issue: #2781.

Unfortunately Smack (the library used by Jitsi and Spark) doesn't follow specification when it comes to SASL PLAIN and our strict implementation resulted in the experienced error.

Added by Gianluca Lorenzin almost 4 years ago

Ok, but with Tigase 5.2.3 we could connect without problems; there is something new on Tigase 7.0.0 regarding this aspect of implementation?

Added by Gianluca Lorenzin almost 4 years ago

I saw related issue #2781 and I try to add: --sasl-strict=true to init.properties but nothing changes...

Added by Wojciech Kapcia TigaseTeam almost 4 years ago

Gianluca Lorenzin wrote:

Ok, but with Tigase 5.2.3 we could connect without problems; there is something new on Tigase 7.0.0 regarding this aspect of implementation?

As I said - this change was introduced in the version 7.0.0 therefore the difference.

Gianluca Lorenzin wrote:

I saw related issue #2781 and I try to add: [...] to init.properties but nothing changes...

This property was added shortly after 7.0.0 release. It will be available shortly in the next minor release to deal with the clients that break the specification.

Added by Gianluca Lorenzin almost 4 years ago

Ok, thank you for the answer.

    (1-6/6)