Project

General

Profile

admin accout login fail on linux

shir Hu
Added almost 4 years ago

Hi,

I install tigase server 7.0.0 on my linux device, try to login with account admin@etw.im/tigase, but failed, error as follow:

 java.io.IOException: Password verification problem.
    at tigase.auth.impl.AuthRepoPlainCallbackHandler.handleVerifyPasswordCallback(AuthRepoPlainCallbackHandler.java:139)
    at tigase.auth.impl.AuthRepoPlainCallbackHandler.handleCallback(AuthRepoPlainCallbackHandler.java:92)
    at tigase.auth.impl.AuthRepoPlainCallbackHandler.handle(AuthRepoPlainCallbackHandler.java:65)
    at tigase.xmpp.impl.JabberIqAuth.doAuth(JabberIqAuth.java:319)
    at tigase.xmpp.impl.JabberIqAuth.process(JabberIqAuth.java:237)
    at tigase.server.xmppsession.SessionManager$ProcessorWorkerThread.process(SessionManager.java:2434)
    at tigase.util.WorkerThread.run(WorkerThread.java:128)
Caused by: tigase.db.UserNotFoundException: User does not exist: admin@etw.im, in database: jdbc:mysql://192.168.2.33:3306/tigasedb?autoReconnect=true&user=root&password=123456&useUnicode=true&characterEncoding=UTF-8
    at tigase.db.jdbc.TigaseCustomAuth.userLoginAuth(TigaseCustomAuth.java:886)
    at tigase.db.jdbc.TigaseCustomAuth.plainAuth(TigaseCustomAuth.java:618)
    at tigase.db.jdbc.TigaseCustomAuth.otherAuth(TigaseCustomAuth.java:601)
    at tigase.db.AuthRepositoryMDImpl.otherAuth(AuthRepositoryMDImpl.java:173)
    at tigase.auth.impl.AuthRepoPlainCallbackHandler.handleVerifyPasswordCallback(AuthRepoPlainCallbackHandler.java:132)
    at tigase.auth.impl.AuthRepoPlainCallbackHandler.handleCallback(AuthRepoPlainCallbackHandler.java:92)
    at tigase.auth.impl.AuthRepoPlainCallbackHandler.handle(AuthRepoPlainCallbackHandler.java:65)
    at tigase.xmpp.impl.JabberIqAuth.doAuth(JabberIqAuth.java:319)
    at tigase.xmpp.impl.JabberIqAuth.process(JabberIqAuth.java:237)
    at tigase.server.xmppsession.SessionManager$ProcessorWorkerThread.process(SessionManager.java:2434)
    at tigase.util.WorkerThread.run(WorkerThread.java:128)

but when I check db, the record of admin user exist:

[tig_users]
3   admin@etw.im    91a97890045511417b1dc6c02aa0548bd811afe9    tigase  2015-02-10 15:19:44 2015-02-10 15:23:12 2015-02-10 15:26:10 0   0   1
[tig_nodes]
3       3   root

Can you tell me if some config should change on linux unlike windows?


Replies (1)

Added by Wojciech Kapcia TigaseTeam almost 4 years ago

Does other accounts work? How have you created this account (using installer)? There is no need to have different configuration on linux than on windows.

    (1-1/1)