Project

General

Profile

5.2.0 beta 3 problems

Maciej Bursztynowski
Added over 5 years ago

Hi, it's me again.

Paraller to Tigase 5.1.5 installation I'm testing Tigase 5.2.0 beta 3.

I've faced with some problems.

  1. Sometimes Linux Console Installer aletrs "Installation failed" after checking mysql as datastore and disabling postgres and derby going to next screen and it fails, then I run installer again, doing same steps and it continues this step and fails again next step.

  2. So I downloaded .tar.gz package because installer failed. After unpacking, changing permissions and ownership, I've configured init.properties and tigase.conf file. It was looking good so I decided to run tigase 5.2.0 beta3. It failed. After checking log files I noticed that there was problem loading groovy scripts and missing JDBC:MYSQL driver (file jars/mysql-connector-java.jar doesn't work). I've noticed that there is no "libs" directory in tigase beta 3. I've created it and copied files groovy-all.jar and mysql-connector-java.jar to newly created "libs" directory. I've started Tigase and it was running. I was happy until...

  3. I have my own certificate, which works perfect on Tigase 5.1.5, so I copied it to 5.2.0 beta 3, configured init.properties and restarted Tigase. When I tried to connect from my PSI+ client, there was message, that certificate is self-signed by Tigase.org. Log below:

@2013-10-17 11:46:30.982 [main] SSLContextContainer.init() WARNING: Cannot load certficate from file: /opt/tigase

/certs/intranet.xxx.com.pem

java.lang.RuntimeException: Can't sort certificate chain!!!

    at tigase.cert.CertificateUtil.sort(CertificateUtil.java:695)

    at tigase.cert.CertificateUtil.sort(CertificateUtil.java:661)

    at tigase.io.SSLContextContainer.addCertificateEntry(SSLContextContainer.java:199)

    at tigase.io.SSLContextContainer.init(SSLContextContainer.java:410)

    at tigase.io.TLSUtil.configureSSLContext(TLSUtil.java:89)

    at tigase.conf.ConfiguratorAbstract.setProperties(ConfiguratorAbstract.java:812)

    at tigase.conf.ConfiguratorAbstract.setup(ConfiguratorAbstract.java:547)

    at tigase.conf.ConfiguratorAbstract.componentAdded(ConfiguratorAbstract.java:179)

    at tigase.conf.Configurator.componentAdded(Configurator.java:51)

    at tigase.conf.Configurator.componentAdded(Configurator.java:34)

    at tigase.server.AbstractComponentRegistrator.addComponent(AbstractComponentRegistrator.java:115)

    at tigase.server.MessageRouter.addRegistrator(MessageRouter.java:145)

    at tigase.server.MessageRouter.setConfig(MessageRouter.java:700)

    at tigase.server.XMPPServer.start(XMPPServer.java:157)

    at tigase.server.XMPPServer.main(XMPPServer.java:126)@

Certificate is a wildcard (screenshot).

  1. I decided to run tigase as a daemon(user tigase), so I copied file from scrpits/redhat/init.d/tigase to /etc/init.d/ and configured it and changed ownership of tigase files/directories to tigase user. It was running, but message-archive-xep-0136 didn't load. Logs told me that component even didn't try to run but rest of components, plugins and server were working fine. If I run tigase as root message-archive component loads without any errors (I've double checked permission, ownership etc.).
cert.gif (8.76 KB) cert.gif

Replies (6)

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam over 5 years ago

Thank you for reporting all the problems. I have created a ticket and assigned it to one of our team members to look at it: #1596.

As for the missing libs/ folder. We have removed it in version 5.2.0. This is because in previous version jar files were spread over jars/ folder and libs/ folder which caused confusion and complicated deployment and maintenance. Hence we moved all jar files over to the jars/ folder. For the other questions, please wait for Wojciech response.

Added by Maciej Bursztynowski over 5 years ago

I realized, folder libs/ is missing because of moving files to jars/ folder. But it didn't work for me, until I created libs/ dir and copied files there.

May I ask when do you want to release final 5.2.0 version? Can we expect it before Christmas?

Added by Wojciech Kapcia TigaseTeam over 5 years ago

the paths in init.d script wasn't updated for RHEL which may caused the problems, but it was corrected recently and any subsequent release should work correctly; I'm investigating remaining issues.

Added by Wojciech Kapcia TigaseTeam over 5 years ago

Maciej, I've updated the ticket - could you please respond to the questions there?

Added by Maciej Bursztynowski over 5 years ago

Sure, but I need some time to test it.

I'll give feedback in 2 hours.

Is it new tar on server or I need to download it using git?

Added by Wojciech Kapcia TigaseTeam over 5 years ago

you can grab latest nighly

    (1-6/6)