Project

General

Profile

Can't connect to Tigase server running on EC2 Instance: Connection Refused

Eric Johan
Added over 3 years ago

After installing Tigase on an AWS EC2 instance I keep getting the error message 'connection refused' when I try to connect to it using an xmpp client.

The instance is attached to a security group with rules to allow traffic to the necessary ports. I've also tried it with rules allowing all traffic to all ports from all sources but I still get the same message.

I've also checked iptables because I noticed some people needed to configure those as well in specific cases, I made sure it allows all connections but still I can't connect to Tigase.

There are no problems with the installation of Tigase and there seem to be no problems starting Tigase up. I do see the following warning in the log: Resolving default host name: took: 22.

I've read that this shouldn't be a problem unless resolving takes very long. Is 22 to long?

There's also another warning: [sess-man tasks] ThreadExceptionHandler.uncaughtException() SEVERE: Uncaught thread: "sess-man tasks" exception.

This doesn't seem related to my problem but could it be?

Other relevant information

  • SSH (port 22) and HTTP (port 80) work fine

  • Enabling ICMP (ping) on all ports works fine

  • I've tried several xmpp clients, same problem

  • I've deleted and recreated instances several times

  • Re-installed Tigase on fresh instances several times with various configuration options

  • Tried using domain name associated with Elastic IP, normal IP and tried public DNS directly.

  • Configured the DNS in the way necessary for Tigase as described here: http://www.xmppwithtigase.org/installation.html#dns

I've looked everywhere and have not been able to find anything to fix this. Networking isn't my main area of expertise and I'd really appreciate any advice.


Replies (2)

Added by Eric Johan over 3 years ago

Wow, in case anyone ever runs into the same problem: I was using an Amazon Linux AMI and switching to Ubuntu solved the problem. Apparently the Amazon Linux AMIs don't work that well with Tigase.

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam about 3 years ago

Thank you for a followup to your question with a solution.

    (1-2/2)