Project

General

Profile

Newbie about MUC, create, config

István Tóth
Added over 3 years ago

Hi

Can I create permanent MUC in the web admin?

I didn't find any MUC related setup possibility on Web Admin, even I find a rich content about pubsub. I not find even the plug-in, compontent list in web admin, this is some error?

When I try to create MUC form a client, the answer is 'room not exist'. Where can I find a proper IQ to create MUC room?

Thank you


Replies (10)

Added by Daniel Wisnewski IoT 1 Cloud over 3 years ago

Unfortunately we do not have a create room script available from the admin UI. I would recommend checking the component settings from the web ui (which is a full XMPP client) at yourhost:8080/ui/ From there go to Management > Configuration > Manage Active Server Components > muc . If MUC is not listed, you will need to add the component to your init.properties file.

Added by István Tóth over 3 years ago

Hello

I setup the server thru web installer. The problem probably the MUCComponnet typo on install J

--comp-name-1=muc

--comp-class-1=tigase.muc.MUCComponnet

Added by Daniel Wisnewski IoT 1 Cloud over 3 years ago

That would do it, go ahead and edit your init.properties file and fix the typo, should work for you now.

--comp-name-1=muc

--comp-class-1=tigase.muc.MUCComponent

I will check web installer for bug, thanks!

Added by István Tóth over 3 years ago

Hi

I already done it, that was the problem.

After a successful restart, I try to create a presistent, open MUC room.

I make a init.properties change

--comp-name-1=muc

--comp-class-1=tigase.muc.MUCComponent

muc/muc-lock-new-room = false

muc/default_room_config/muc#roomconfig_persistentroom=true

Idea coming from here: https://projects.tigase.org/boards/8/topics/3456

It's look like some syntax error around my lines, because the muc component not start after that.

Added by Daniel Wisnewski IoT 1 Cloud over 3 years ago

MUC rooms are now persistent by default, so you can remove the default room config setting for that.

Added by István Tóth over 3 years ago

Hi

My setup in init.properties

--comp-name-1=muc

--comp-class-1=tigase.muc.MUCComponent

muc/muc-lock-new-room = false

MUC component not run, I can't find in discovery

--comp-name-1=muc

--comp-class-1=tigase.muc.MUCComponent

--muc/muc-lock-new-room = false

MUC component run, but the setting is not live, at management still true.

Probably the spaces the problem?

Added by Wojciech Kapcia TigaseTeam over 3 years ago

Above configurations looks the same?

As for making room persistent - you have to set default room configuration in init.properties and this can be changed during runtime

muc/default_room_config/muc#roomconfig_persistentroom=true

Added by István Tóth over 3 years ago

As you suggest, I left that line, so now the config not contained that.

And my other round with the UTF-8 settings - i don't crearly know that is affected of the mun-lock-new-room thing, but now my setup is:

--comp-name-1=muc

--comp-class-1=tigase.muc.MUCComponent

--muc/muc-lock-new-room=0

The web admin show as:

muc/muc-lock-new-room: true

After all the room isn't seems to be locked anyway, I can send message to it (before that I get 'not enoung privilege to send a group message' error), so I can say it kinda works... :)

Added by Wojciech Kapcia TigaseTeam over 3 years ago

Locked rooms are defined in the MUC specification

What is your expected behaviour? Do you want to have rooms locked (i.e. unavailable before configuration is provided) or persistent (stored to the repository even after last occupant leaves)?

Please also use proper configuration -- component configuration should follow this pattern (wihtout double dashes -- at the beginnign):

/[]=

therefore if you want to enable locked rooms use

muc/muc-lock-new-room[B]=true

and to make room persistent

muc/default_room_config/muc#roomconfig_persistentroom=true

    (1-10/10)