Project

General

Profile

mobile-core build error / cloud Tigase XMPP Server service URL?

DILIP GUNAWARDENA
Added over 3 years ago

mobile-core gives the following pom.xml maven-build build-error:

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : Unsupported major.minor version 51.0

How can I get past this error, and build-and-run the Tigase Android XMPP client on my Android Marshmallow (or Lollipop) devices?

Once I have achieved that, what is the cloud Tigase XMPP Server service URL they should point to?

Thank you very much and best regards


Replies (1)

Added by Andrzej Wójcik IoT 1 CloudTigaseTeam about 3 years ago

From Unsupported major.minor version 51.0 I can say that you use JDK6 for compilation while JDK7 is required - see http://stackoverflow.com/questions/10382929/how-to-fix-unsupported-major-minor-version-51-0-error

I do not know what cloud Tigase XMPP Server service URL you expect. We use JID to detect domain and using SRV records to detect address of server to connect - so no cloud URL for service.

    (1-1/1)