Project

General

Profile

Create Node Script is failing with [remote-server-not-found, text]

Abhinav Gupta
Added over 3 years ago

Hi,

I am using Tigase 7.0.2 server and trying to enable pubsub component.

Whenever I try to execute the create node script the following comes.

~/Downloads/tclmt-1.0.0-SNAPSHOT$ sudo sh ./bin/tclmt.sh -u admin@tigase2 -p tigase remote pubsub.tigase create-node example admin@tigase leafOct 29, 2015 4:47:53 PM tigase.xml.db.XMLDB setupNewDB

INFO: Create empty DB.

awaiting response...

Errors: [remote-server-not-found, text]

java.net.SocketException: Socket is closed

Not sure how to proceed with this.

Any advise and suggestions are appreciated.

Thanks in Advance.

I am attaching here the tigase log and console log and properties file.


Replies (10)

Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 3 years ago

I think you have an error in parameter passed to TCLMT as you passed pubsub.tigase as a component name while you passed admin@tigase2 as user - I suppose you should pass pubsub.tigase2

Also please check rest of you parameters as I see admin@tigase passed as an owner which I think should be admin@tigase2.

Added by Abhinav Gupta over 3 years ago

Hi Andrezej,

Thanks for the reply.

Sorry for the delayed response.

now I am trying below,

but still facing the same error

Please review and let me know what I am doing wrong.

sh bin/tclmt.sh -u admin@localhost remote pubsub.blackbuck create-node Operations admin@blackbuck leaf

when i remove the remote part from the above command, i get

sh bin/tclmt.sh -u admin@localhost create-node Operations admin@blackbuck leaf

this error below,

Nov 14, 2015 9:48:47 PM tigase.xml.db.XMLDB setupNewDB

INFO: Create empty DB.

No script with id create-node

Please help me, any suggestions/advise are much appreciated.

Thanks and Regards,

Abhinav

Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 3 years ago

remote is required parameter for create-node to work properly.

Is blackbuck domain hosted on your server? Is it configured as hosted vhost? If not then this is a cause of this error.

Added by Abhinav Gupta over 3 years ago

it is configured as the virtual hosts at the time of installation of tigase server in my system.

This is the also listed in my init.properties file.

--virt-hosts = blackbuck

do i have to configure it somewhere else as well.

Added by Abhinav Gupta over 3 years ago

I have modifed the hosts file to reflect blackbuck

Now I am getting this error below,

vostro@vostro-Vostro-3546:~/tigase/tclmt$ sh bin/tclmt.sh -u admin@localhost remote pubsub.blackbuck create-node Operations admin@blackbuck leaf

Nov 16, 2015 10:46:50 AM tigase.xml.db.XMLDB setupNewDB

INFO: Create empty DB.

awaiting response...

tigase.jaxmpp.core.client.exceptions.JaxmppException: Not connected!

at tigase.jaxmpp.core.client.JaxmppCore$1.write(JaxmppCore.java:143)

at tigase.jaxmpp.core.client.JaxmppCore$1.write(JaxmppCore.java:164)

at tigase.jaxmpp.core.client.JaxmppCore.send(JaxmppCore.java:413)

at tigase.tclmt.JaxmppConnection.sendSync(JaxmppConnection.java:45)

at tigase.tclmt.JaxmppConnection.sendSync(JaxmppConnection.java:39)

at tigase.tclmt.SynchronizedConnection$sendSync.call(Unknown Source)

at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:42)

at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:108)

at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:116)

at Script1.run(Script1.groovy:51)

at org.codehaus.groovy.jsr223.GroovyScriptEngineImpl.eval(GroovyScriptEngineImpl.java:315)

at org.codehaus.groovy.jsr223.GroovyCompiledScript.eval(GroovyCompiledScript.java:41)

at tigase.tclmt.Script.execute(Script.java:94)

at tigase.tclmt.CommandManager.executeScript(CommandManager.java:72)

at tigase.tclmt.Tclmt.execute(Tclmt.java:178)

at tigase.tclmt.Tclmt.main(Tclmt.java:226)

Is there a specific convention to reflect pubsub with domain(for example blackbuck), I am thinking maybe this is the reason for the error.

Regarding virtual hosts, i have modified the hosts file, but do I have to install the apache server and add the vhost parameter there as well for this to work?

Please review and let me know your thoughts.

Thanks for the support you have provided so far.

Added by Abhinav Gupta over 3 years ago

Hi Everyone,

I am facing this error now, when i tried to create a node from tclmt client,

vostro@vostro-Vostro-3546:~/tigase/tclmt$ sh bin/tclmt.sh -u admin@blackbuck remote pubsub.blackbuck create-node Operations admin@blackbuck leaf

Nov 16, 2015 3:28:20 PM tigase.xml.db.XMLDB setupNewDB

INFO: Create empty DB.

awaiting response...

Errors: [feature-not-implemented]

Please review and assist.

Attaching the init file and log files, and host files.

Any Suggestions and advice is welcomed.

Added by Abhinav Gupta over 3 years ago

When I tried below,

sh bin/tclmt.sh -u admin@blackbuck remote pubsub@blackbuck create-node Operations admin@blackbuck leaf

I got

vostro@vostro-Vostro-3546:~/tigase/tclmt$ sh bin/tclmt.sh -u admin@blackbuck remote pubsub@blackbuck create-node Operations admin@blackbuck leafNov 16, 2015 3:42:16 PM tigase.xml.db.XMLDB setupNewDB

INFO: Create empty DB.

awaiting response...

Errors: [forbidden, text]

Please review.

Added by Wojciech Kapcia TigaseTeam over 3 years ago

Abhinav Gupta wrote:

awaiting response...

Errors: [forbidden, text]

is admin@blackbuck configured as admin?

Added by Daniel Wisnewski IoT 1 Cloud over 3 years ago

Try changing pubsub address to pubsub.blackbuck

everything else seems to be in order, and admin@blackbuck is configured right.

Added by Abhinav Gupta over 3 years ago

Hi,

I got it to work by adding blackbuck to the hosts file.

Thanks for taking the time to review the case.

btw, it worked only when i used the pubsub@blackbuck not pubsub.blaclbuck and i added the pubsub@blackbuck to the admins as well.

    (1-10/10)