Project

General

Profile

Server does not start Windows10/ MS SQL

Sassine Jaoude
Added about 3 years ago

I am trying to install the server on windows 10 with an MS SQL DB.

Tried both 7.0.1 and 7.0.2 - the installation seems to go fine (I can see the DB with tables created, etc.).

However, the server does not start (not as a service nor from run.bat) .

I was advised to grab a nightly build for windows.

1- Where would these builds be located ?

2- The run.bat produces 3 or 4 warnings but no errors (WARNING: Dumping server configuration to: etc/config-dump.properties).

I understand that ultimately we will not be hosting on a windows machine.

But we need to get myself familiar with the server/db etc... on my environment.

Can someone please advise on the best way to make this work.

Thanks


Replies (1)

Added by Daniel Wisnewski IoT 1 Cloud about 3 years ago

Hello Sassine,

If the console window shows dumping server configuration, the server has finished loading and is running.

How are you attempting to connect to the server or check that it is running?

Nightlies distributions are available here: http://build.xmpp-test.net/nightlies/dists/ However these are not final builds and may have other issues. ALso if you are upgrading an installation to a nightly, you will need to update the pubsub schema and instructions are here: http://docs.tigase.org/tigase-server/snapshot/Administration_Guide/html/#tigaseServer71

I can confirm that Tigase works well in a windows environment, but it can be a bit cumbersome at times.

Dan

    (1-1/1)