Project

General

Profile

Clear install. Postgresql. User can't connect

Alex Kobzar
Added almost 3 years ago

Hi.

I try to use Tigase, but i'm stuck at start.

Centos 7. JDK 8_0

init.propertis

--comp-class-1 = tigase.muc.MUCComponent
--vhost-anonymous-enabled=false
--vhost-tls-required=false
--virt-hosts = xmpp.domain.com
--user-db-uri = jdbc:postgresql://server_ip/tigasedb?user=username&password=passwd&useUnicode=true&characterEncoding=UTF-8
--user-db = pgsql
--admins = admin@xmpp.domain.com
--comp-name-4 = message-archive
--comp-name-3 = proxy
config-type = --gen-config-def
--comp-name-2 = pubsub
--comp-name-1 = muc
--cluster-mode = false
--sm-plugins = +message-archive-xep-0136
--debug = server,db,xmpp.impl
--comp-class-4 = tigase.archive.MessageArchiveComponent
--comp-class-3 = tigase.socks5.Socks5ProxyComponent
--comp-class-2 = tigase.pubsub.PubSubComponent

part of log

2016-02-22 07:31:55.086 [in_99-message-router]  MessageRouter.getLocalComponent()  FINEST: No componentID matches (fast lookup against exact address): c2s@localhost/server_ip_5222_client_ip_59050, for map: [amp@localhost, bosh@localhost, c2s@localhost, basic-conf@localhost, stats@localhost, monitor@localhost, message-archive@localhost, vhost-man@localhost, muc@localhost, proxy@localhost, ws2s@localhost, pubsub@localhost, s2s@localhost]; trying VHost lookup
2016-02-22 07:31:55.086 [in_99-message-router]  MessageRouter.processPacket()  FINEST:  1. Packet will be processed by: c2s@localhost, from=sess-man@localhost, to=c2s@localhost/server_ip_5222_client_ip_59050, DATA=<iq from="sess-man@localhost" to="c2s@localhost/server_ip_5222_client_ip_59050" id="ssl_sdfs-43d2-43f5-a7c1-1ee719378f46" type="error"><command node="GETFEATURES" xmlns="http://jabber.org/protocol/commands"/><error type="modify" code="406"><not-acceptable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/><text xmlns="urn:ietf:params:xml:ns:xmpp-stanzas" xml:lang="en">S2S - Incorrect source address - none of any local virtual hosts or components.</text></error></iq>, SIZE=477, XMLNS=null, PRIORITY=HIGH, PERMISSION=NONE, TYPE=error
2016-02-22 07:31:55.087 [in_99-c2s]        ClientConnectionManager.processPacket()  FINEST: Processing packet: from=sess-man@localhost, to=c2s@localhost/server_ip_5222_client_ip_59050, DATA=<iq from="sess-man@localhost" to="c2s@localhost/server_ip_5222_client_ip_59050" id="ssl_fb256385-43d2-43f5-a7c1-1ee719378f46" type="error"><command node="GETFEATURES" xmlns="http://jabber.org/protocol/commands"/><error type="modify" code="406"><not-acceptable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/><text xmlns="urn:ietf:params:xml:ns:xmpp-stanzas" xml:lang="en">CData size: 79</text></error></iq>, SIZE=477, XMLNS=null, PRIORITY=HIGH, PERMISSION=NONE, TYPE=error
  1. hostname

xmpp.domain.com

user is present in tig_users

where i have mistake?


Replies (4)

Added by Wojciech Kapcia TigaseTeam almost 3 years ago

From the provided log excerpt it's impossible to answer you question - it only describes the routing of error packet.

Your configuration looks good.

Added by Alex Kobzar almost 3 years ago

So, how i can find issue? I can't understand why server isn't work now?

Added by Wojciech Kapcia TigaseTeam almost 3 years ago

You need to investigate all logs, not only 3 lines. Look at connection starting point.

Added by Alex Kobzar almost 3 years ago

You can close this topic.

    (1-4/4)