Project

General

Profile

Installation with maven fails

Rai Ehtisham
Added about 3 years ago

Hi guys,

I am trying to install tigase with mysql using maven and i'm getting a lot of errors on each step.

Tried a couple of tricks, one step passes and the next one fails.

Now trying a fresh copy of the repo from https://repository.tigase.org/git/tigase-server.git

In the tigase-server folder i executed the command

mvn clean install and it gave the below output

@[INFO] BUILD SUCCESS

[INFO] ------------------------------------------------------------------------

[INFO] Total time: 1:05.841s

[INFO] Finished at: Wed Mar 16 12:49:33 PKT 2016

[INFO] Final Memory: 34M/563M@

Now when I start the server it gives error

@TIGASE_HOME is not set.

Please set it to correct value before starting the sever.@

tigase.sh and init.properties files are attached.

Please help


Replies (7)

Added by Rai Ehtisham about 3 years ago

I'm looking for a walkthrough for installation with maven

Added by Daniel Wisnewski IoT 1 Cloud about 3 years ago

Hello Rai,

Try building Tigase from git directory using the following command

mvn -Pdist -f modules/master/pom.xml clean install

This will generate -dist-max archives, which you can unpack and run from there.

Added by Rai Ehtisham about 3 years ago

@[INFO] Reactor Summary:

[INFO]

[INFO] Tigase XMPP Server Master project ................. SUCCESS [2.278s]

[INFO] Tigase XMPP Server ................................ SUCCESS [1:05.358s]

[INFO] Tigase XMPP Server Distribution builder ........... FAILURE [0.207s]

[INFO] ------------------------------------------------------------------------

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time: 1:08.593s

[INFO] Finished at: Mon Mar 21 15:40:30 PKT 2016

[INFO] Final Memory: 42M/651M

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal on project tigase-server-dist: Could not resolve dependencies for project tigase:tigase-server-dist:pom:7.2.0-SNAPSHOT: The following artifacts could not be resolved: tigase:tigase-message-archiving:jar:1.3.0-SNAPSHOT, tigase:tigase-unified-archive:jar:1.1.0-SNAPSHOT: Failure to find tigase:tigase-message-archiving:jar:1.3.0-SNAPSHOT in http://maven.tigase.org was cached in the local repository, resolution will not be reattempted until the update interval of tigase has elapsed or updates are forced -> [Help 1]@

I get this error when I run the

mvn -Pdist -f modeuls/master/pom.xml clean install

By the way I have been able to install it with simple mvn clean install but now when I add muc to my init.properties file and start the server, it gives error

can't load module muc

But my one to one chat is working

What could be the problem in both cases?

Added by Daniel Wisnewski IoT 1 Cloud about 3 years ago

Tigase v7.2.0 is still in heavy development, and I believe the MUC code is still undergoing some work. Have you tried -U switch to force updates?

One to one chat is part of the main program, whereas MUC rooms are handled by the muc component, the XMPP server can run without MUC component enabled.

If you are looking for a more stable version, check out v7.1.0 is more stable and is nearly finished. It is available as 'release' branch of the program.

Added by Rai Ehtisham about 3 years ago

That helped, thank a lot.

I have also set the MUC property for persistent rooms in init.properties like this

muc/default_room_config/muc#roomconfig_persistentroom=true

Question is, where does it store the room details and the members of the rooms?

Added by Wojciech Kapcia TigaseTeam about 3 years ago

In the user repository under the user multi-user-chat (please read http://docs.tigase.org/tigase-server/snapshot/Development_Guide/html_chunk/tigaseDBSchema.html to get more information about the structure).

    (1-7/7)