Project

General

Profile

Unable to connect to tigase xmpp server

Mohamad Nachabe
Added about 2 years ago

Hi, I'm getting the following log when I try to connect from the tigase mobile messenger to the server.

@2017-01-24 09:10:57.510 [ConnectionOpenThread] ConnectionManager$ConnectionListenerImpl.accept() FINEST: Accept called for service: null@null, port_props: {type=accept, socket=plain, ifc=[Ljava.lang.String;@437ebf59, remote-host=localhost, required=false, port-no=5222}

2017-01-24 09:10:57.510 [ConnectionOpenThread] ConnectionManager.serviceStarted() FINER: c2s Connection started: null, type: accept, Socket: nullSocket[addr=/192.168.2.101,port=42135,localport=5222], jid: null

2017-01-24 09:10:57.511 [pool-15-thread-9] ClientConnectionManager.xmppStreamOpened() FINER: Stream opened: {xmlns:stream=http://etherx.jabber.org/streams, xmlns=jabber:client, from=sherifelkhatib@192.168.2.121, to=192.168.2.121, version=1.0}

2017-01-24 09:10:57.512 [pool-15-thread-9] ConnectionManager.serviceStopped() FINER: c2s Connection stopped: c2s@user-pc/192.168.2.121_5222_192.168.2.101_42135, type: accept, Socket: c2s@user-pc/192.168.2.121_5222_192.168.2.101_42135 Socket[unconnected], jid: null

2017-01-24 09:10:57.512 [pool-15-thread-9] ClientConnectionManager.xmppStreamClosed() FINER: Stream closed: c2s@user-pc/192.168.2.121_5222_192.168.2.101_42135@

The error appearing on the mobile app is: Account:mohamadnachabe@192.168.2.121 Connection error: Unknown host 192.168.2.121

Also, this is my init.properties:

--comp-class-1 = tigase.muc.MUCComponent
--virt-hosts = user-pc
--user-db-uri = jdbc:mysql://localhost/tigasedb?user=tigase&password=******
--user-db = mysql
--admins = admin@user-pc, mohamadnachabe@user-pc
--comp-name-4 = message-archive
--comp-name-3 = proxy
config-type = --gen-config-def
--comp-name-2 = pubsub
--comp-name-1 = muc
--cluster-mode = true
--sm-plugins = +message-archive-xep-0136
--debug = server
--comp-class-4 = tigase.archive.MessageArchiveComponent
--comp-class-3 = tigase.socks5.Socks5ProxyComponent
--comp-class-2 = tigase.pubsub.PubSubComponent

Any thoughts on this please?


Replies (1)

Added by Mohamad Nachabe about 2 years ago

I tried changing the virt-hosts to my ip address, and it all worked.

    (1-1/1)