Project

General

Profile

XMPP server is not working on IP

praveen kumar
Added 2 months ago

Hi, Team.

My XMPP is working fine on localhost and on IP. but I am not able to create a user on Tigase.im service to IP address. it's working only on localhost. Please help to resolve this on IP address.


Replies (3)

Added by Daniel Wisnewski 2 months ago

Hi there,
XMPP by default does not use IP addresses to deliver packets, rather they will go to a FQDN of the server itself.
I am a bit confused at the question however. Are you attempting to create users on our tigase.im service? Or are you trying to create users on your local machine?

Added by praveen kumar 2 months ago

my XMPP is setup on localhost.If I create a user using tigase.im service as test1@localhost it will create the user. but if I use my IP as it will not create the user. I want to use IP to create a user from my machine and another machine in same network.

Added by Wojciech Kapcia 2 months ago

praveen kumar wrote:

my XMPP is setup on localhost.If I create a user using tigase.im service as test1@localhost it will create the user. but if I use my IP as it will not create the user.

How are you exactly creating those users and what error do you receive?

I want to use IP to create a user from my machine and another machine in same network.

As Daniel said - using IPs is generally discouraged and you should use domain names (even though those will be used only as identifiers so requiring correct routing will be required).

Why are you trying to use IPs instead of FQDN?

    (1-3/3)