Project

General

Profile

S2S - Incorrect source address - none of any local virtual hosts or components.

chris wang
Added 3 months ago

2018-08-01 22:41:45.105 [in_22-s2s] S2SConnectionManager.processPacket() WARNING: Packet processing exception: {0}
tigase.xmpp.PacketErrorTypeException: The packet has already 'error' type: from=node1, to=dev01, DATA=S2S - Incorrect source address - none of any local virtual hosts or components., SIZE=343, XMLNS=null, PRIORITY=NORMAL, PERMISSION=NONE, TYPE=error
at tigase.xmpp.Authorization.getResponseMessage(Authorization.java:539)
at tigase.server.xmppserver.S2SConnectionManager.processPacket(S2SConnectionManager.java:324)
at tigase.server.AbstractMessageReceiver$QueueListener.run(AbstractMessageReceiver.java:1426)

init.propeties

config-type = --gen-config-def
--admins = admin@app.im
--virt-hosts = app.im

--cluster-mode = true
--cluster-nodes = node1,dev01
--cluster-connect-all = true
vhost-man/dns-def-ip[S]=app.im

--debug=server,cluster


Replies (3)

Added by chris wang 3 months ago

on node1 log:
S2C: <route to="dev01" from="node1" pr="NORMAL" perm="NONE"><iq to="dev01" type="error" id="tigase-ping" from="node1"><ping xmlns="urn:xmpp:ping"/><error code="406" type="modify"><not-acceptable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/><text xmlns="urn:ietf:params:xml:ns:xmpp-stanzas" xml:lang="en">S2S - Incorrect source address - none of any local virtual hosts or components.</text></error></iq></route>
C2S: <route perm="NONE" from="node1" to="dev01" pr="NORMAL"><iq type="error" id="tigase-ping" from="node1" to="dev01"><ping xmlns="urn:xmpp:ping"/><error type="modify" code="406"><not-acceptable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/><text xml:lang="en" xmlns="urn:ietf:params:xml:ns:xmpp-stanzas">S2S - Incorrect source address - none of any local virtual hosts or components.</text></error></iq></route>

Added by chris wang 3 months ago

S2C: <route to="dev01" from="node1" pr="NORMAL" perm="NONE"><iq to="dev01" type="error" id="tigase-ping" from="node1"><ping xmlns="urn:xmpp:ping"/><error code="406" type="modify"><not-acceptable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/><text xmlns="urn:ietf:params:xml:ns:xmpp-stanzas" xml:lang="en">S2S - Incorrect source address - none of any local virtual hosts or components.</text></error></iq></route>

config update

config-type = --gen-config-def
--admins = admin@app.im
--virt-hosts = app.im


--cluster-mode = true
--cluster-nodes = node1,dev01
--cluster-connect-all = true
vhost-man/dns-def-ip[S]=app.im

--debug=server,cluster

Added by chris wang 3 months ago

problem fixed. thanks

    (1-3/3)