Project

General

Profile

Not Authorized error in Pidgin[SOLVED]

m m
Added over 5 years ago

I've installed Tigase XMPP server; i also created a self-signed certificate for the server. After installation i set the --ssl-container-class=tigase.extras.io.PEMSSLContextContainer option in the init.properties file and i copied my pem and crt files that i generated to cert folder. I started the server and it started successfully.

In installation time i gave my server an IP address instead of domain name. In the Pidgin i entered a user name i also created the user on the server side using the TigAddUserPlainPw stored procedure. Pidgin gets my certificat and i accept it but it still gives me "Not Authorized" error.

Can anyone tell me why?


Replies (4)

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam over 5 years ago

The domain name is a part of a user ID used for a password verification. Therefore the domain (or IP) have to match what you put in the database, Tigase configuration and the client (Pidgin) configuration.

Added by m m over 5 years ago

So how do i supposed to add users? I added another user using TigAddUserPlainPw('mine@192.168.20.105','123456'). Also in the Advanced configuration tab of Pidgin i entered the server IP manually. Then i entered mine as username and 192.168.20.105 as hostname; then it gives me "Host Unknown" error. When i change my hostname to debian it gives me 'Not Authorized' error!!! How can i solve this problem??

Added by m m over 5 years ago

I tried connecting using another client: GNU Freetalk. it works!!! But i can not connect using Pidgin! it is strange. After some modifications Pidgin now gives me 501 Feature not implemented error!

Added by m m over 5 years ago

I found the problem!!! The main reason for 501 Not implemented is the Pidgin itself!!! When you do not specify a resource in the resource field it adds an empty slash at the end of the request and causes the server to return this error. Usign GNU Freetalk does not have this problem!

    (1-4/4)