Project

General

Profile

tigase 8.0 cluster strategy: tigase.server.cluster.strategy.OnlineUsersCachingStrategy Could not initialize bean sess-man (class: class tigase.cluster.SessionManagerClustered)

w xy
Added 5 months ago

'sess-man' () {

amp {
    'amp-repo-class' = 'tigase.mongodb.MongoMsgRepository'
    'amp-repo-uri' = 'mongodb://192.168.97.132:27017/tigase'
}
'jabber:iq:register' () {}

strategy (class: tigase.server.cluster.strategy.OnlineUsersCachingStrategy) {}
starttls (active: false) {}

}

There is a error with starting xmpp server:

2018-11-05 11:02:49.527 [main] Kernel.injectDependencies() WARNING:

=====================
Could not initialize bean strategy (class: class tigase.server.cluster.strategy.OnlineUsersCachingStrategy), skipping injection of this bean
RootCause:
-> tigase.kernel.KernelException: Cannot inject configuration to bean strategy
[tigase.kernel.beans.config.AbstractBeanConfigurator.configure(AbstractBeanConfigurator.java:410)]
-> tigase.kernel.KernelException: Cannot grab default values of bean strategy
[tigase.kernel.beans.config.AbstractBeanConfigurator.grabDefaultConfig(AbstractBeanConfigurator.java:637)]
-> java.lang.NullPointerException

=====================

=====================
Could not initialize bean sess-man (class: class tigase.cluster.SessionManagerClustered), skipping injection of this bean
RootCause:
-> tigase.kernel.KernelException: Can't inject null to field tigase.cluster.SessionManagerClustered.strategy

[tigase.kernel.core.Kernel.inject(Kernel.java:1206)]

2018-11-05 11:24:17.247 [main] Kernel.injectDependencies() WARNING:

=====================
Could not initialize bean sess-man (class: class tigase.cluster.SessionManagerClustered), skipping injection of this bean
RootCause:
-> tigase.kernel.KernelException: Cannot inject configuration to bean sess-man
[tigase.kernel.beans.config.AbstractBeanConfigurator.configure(AbstractBeanConfigurator.java:410)]
-> tigase.kernel.KernelException: Cannot grab default values of bean sess-man
[tigase.kernel.beans.config.AbstractBeanConfigurator.grabDefaultConfig(AbstractBeanConfigurator.java:637)]
-> java.lang.NullPointerException

=====================

What can i do for solving the problem? Thanks a lot.


Replies (2)

Added by Andrzej Wójcik IoT 1 CloudTigaseTeam 5 months ago

I'm not sure why you are asking this question in TIgase HTTP API forum as it would better fit in https://tigase.tech/projects/1/boards/15.

It is hard to tell why it is behaving this way only with data which you provided, as we do not know all your configuration and installation details.

  1. Do you have clustering enabled in your configuration? (OnlineUsersCachingStrategy is available only with clustering enabled).

  2. OnlineUsersCachingStrategy is available in Tigase ACS package (part of Tigase dist-max package). Do you have tigase-acs.jar in jars directory of your installation?

Added by w xy 5 months ago

config like this, but not all. and there is a tigase-acs.jar with jars.

'config-type' = 'default'
admins = [ '10005@xmpp.server' ]

debug = [server,xmpp,shiku,db,net]
default-virtual-host = 'xmpp.server'

watchdog_delay = 30000
watchdog_ping_type = 'xmpp'

watchdog_timeout = 10000

'cluster-mode' = true
cm-ht-traffic-throttling' = 'xmpp:25k:0:disc,bin:200m:0:disc'

'cl-comp' {
'connect-all' = true

'cluster-connections-per-node' = 1

'repo-autoreload-interval' = 180

}

#customer

--confirm-open-keyword = 0

dataSource {
default () {
uri = 'mongodb://192.168.97.132:27017/tigase'
'schema-management' = false
}
muc-store () {
uri = 'mongodb://192.168.97.132:27017/imRoom'
'schema-management' = false
}
}

userRepository {
default () {
cls = 'tigase.mongodb.MongoRepository'
}
}
authRepository {
default () {
cls = 'tigase.mongodb.MongoRepository'
}
}

amp {
'amp-repo-class' = 'tigase.mongodb.MongoMsgRepository'
'amp-repo-uri' = 'mongodb://192.168.97.132:27017/tigase'
}

'message-router' {
'incoming-filters' = 'tigase.shiku.ShikuKeywordFilter'
}

muc (class: tigase.muc.cluster.MUCComponentClustered) {
muc-dao {
default () {
dataSourceName = 'muc-store'
'schema-management' = false
}
}
'history-db' = 'tigase.mongodb.muc.MongoHistoryProvider'

 'muc-lock-new-room'= false
 defaultRoomConfig  {
    'muc#maxhistoryfetch' = '100'
}

}

'sess-man' () {

amp {
    'amp-repo-class' = 'tigase.mongodb.MongoMsgRepository'
    'amp-repo-uri' = 'mongodb://192.168.97.132:27017/tigase'
}
'jabber:iq:register' () {}


strategy (class: tigase.server.cluster.strategy.OnlineUsersCachingStrategy) {}
starttls (active: false) {}

}

    (1-2/2)