Project

General

Profile

tig_ma_msgs table is empty

Sunil Kumar
Added almost 5 years ago

Hi,

I have set my init.properties file as below:

I am unable to get the messages history into table tig_ma_msgs; it returns empty table. i am using tigase server 5.2.x.

Please help me around.

<<<<< init.properties file start >>>>>>>>

--comp-class-1 = tigase.muc.cluster.MUCComponentClustered
--virt-hosts = lpt-suniperi
--auth-db-uri = jdbc:mysql://localhost:3306/tigasedb?user=root&password=admin
--user-db-uri = jdbc:mysql://localhost:3306/tigasedb?user=root&password=admin
--message-archive/archive-repo-uri=jdbc:mysql://localhost:3306/tigasedb?user=root&password=admin
--message-archive/auto=true
--sess-man/plugins-conf/message-archive-xep-0136/component-jid=admin@lpt-suniperi
--user-db = mysql
--admins = admin@lpt-suniperi
--comp-name-6 = message-archive
--comp-name-5 = rest
#--comp-name-4 = stun
--auth-db = mysql
--comp-name-3 = proxy
config-type = --gen-config-all
--comp-name-2 = pubsub
--comp-name-1 = muc
--cluster-mode = false
--sm-plugins = +message-archive-xep-0136,+jabber:iq:auth,+urn:ietf:params:xml:ns:xmpp-sasl,+urn:ietf:params:xml:ns:xmpp-bind,+urn:ietf:params:xml:ns:xmpp-session,+jabber:iq:register,+jabber:iq:roster,+presence,+jabber:iq:privacy,+jabber:iq:version,+http://jabber.org/protocol/stats,+starttls,+msgoffline,+vcard-temp,+http://jabber.org/protocol/commands,+jabber:iq:private,+urn:xmpp:ping,+basic-filter,+domain-filter,+pep,-zlib
--comp-class-6 = tigase.archive.MessageArchiveComponent
--debug = server,xmpp.impl,db,cluster
--comp-class-5 = tigase.http.rest.RestMessageReceiver
#--comp-class-4 = tigase.stun.StunComponent
--comp-class-3 = tigase.socks5.Socks5ProxyComponent
--comp-class-2 = tigase.pubsub.cluster.PubSubComponentClustered

<<<<< init.properties file end >>>>>>>>


Replies (9)

Added by Wojciech Kapcia TigaseTeam almost 5 years ago

As per XEP-0136 you need to explicitly enable archiving for each client:

<iq type='set' id='auto1'>
  <auto save='true' xmlns='urn:xmpp:archive'/>
</iq>

Added by Sunil Kumar almost 5 years ago

Thanks for the response Kapcia.

Where should the above entry to be appended. Any specific file.

Kindly let me know the name of the file.

Added by Sunil Kumar almost 5 years ago

I have already set the message-archive-auto to true in init.properties file.

--message-archive/auto=true

Added by Wojciech Kapcia TigaseTeam almost 5 years ago

You don't put this into configuration - you send this stanza from the user to the server after establishing the session to enable logging of the messages for that particular user.

Added by Sunil Kumar almost 5 years ago

I am a newbie to XMPP. I have installed Tigase server & then connecting my users to Tigase using an universal client such as Pidgin.

Now to archive messages from such clients is there a way to persist on the Tigase's database.

Added by Sunil Kumar almost 5 years ago

Thanks Kapcia for the instant support. I understood what stanza's are.

I am successful in archiving the txt msgs.

Do you mean even attachments shall also be enabled the same way.

Added by Wojciech Kapcia TigaseTeam almost 5 years ago

Sunil Kumar wrote:

Do you mean even attachments shall also be enabled the same way.

what 'attachments'?

Added by Sunil Kumar almost 5 years ago

I was referring to the file transfers between users. Is there a way to persist the files being transferred to a database table.

Added by Wojciech Kapcia TigaseTeam almost 5 years ago

How are the files being transferred? There are a few possibilities here (using inband file transfer, socks5 proxy, jingle).

    (1-9/9)