Project

General

Profile

Multiple items in Message archive with same data

István Tóth
Added about 3 years ago

Hello.

I see in the DB multiple lines with same datas in the Message Archive table. I attach a screenshoot too.

Also if special char apperar in the archive, like ő, ú, í, the XML stanza broken / 'Date format error' message appear in the result stanza.

(I remember a same error somewhere around this forum, but I cannot find it again...)

tigaseerr0003.png (215 KB) tigaseerr0003.png Tigase Message archive multiple items with same data.

Replies (4)

Added by Wojciech Kapcia TigaseTeam about 3 years ago

Which version of the Tigase/Message archive component do you use? With which database?

In case of mysql you should append &useUnicode=true&characterEncoding=UTF-8 to the DB URI. If the schema was created without it please check encoding and collation of the tables.

Added by István Tóth about 3 years ago

Hi

I checked it already, its: Version=1.1.0-b71/c4003eb3

I make the changes in the config

Added by István Tóth about 3 years ago

Hello

I make the changes in the config, the multiple item issue look like solved, but with special chars, still broke.

I attached images.

Look like the tigase bosh header length is not correct, when some special char in the xml stanza...

tigase0004.png (144 KB) tigase0004.png Collation setup
tigase0005.png (103 KB) tigase0005.png db item list after the conf setup - with spec char
tigase0006.png (16.9 KB) tigase0006.png config in init.prop
tigase0007.png (56.5 KB) tigase0007.png After remove spec char from db, the xml stanza right

Added by Wojciech Kapcia TigaseTeam about 3 years ago

As I said in previous message:

please check encoding and collation of the tables.

    (1-4/4)