Project

General

Profile

Disable Tigase logging

nurnabi siddique
Added almost 5 years ago

Dear Altruists,

          Is there any way to disable server logging?

Replies (6)

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam almost 5 years ago

If you remove form the init.properties file line starting with:

--debug

The server will log very little data, only essential, warning and critical. We highly recommend to keep it on at least this default level as these logs provide essential information for the server troubleshooting.

If you really want to completely disable logging, then it is possible but a bit tricky.

Added by David Leder almost 5 years ago

Hi

I have the following messages:

2014-03-26 01:37:06.582 [pool-12-thread-17] BoshSession.sendBody() INFO: No waitTimer for the Bosh connection! bosh@u0705.ndzs.ch.netstream.com/11.11.11.11_5280_12.12.12.12_27663, type: accept, Socket: bosh@example.com/11.11.11.11_5280_12.12.12.12_27663 Socket[addr=/12.12.12.12,port=27663,localport=5280], jid: null

I'm totally aware, that my machine is not being able to handle as many requests. Nevertheless, this is caused by high load of the logging, which uses the disks more than I want to give to them.

Is there any method to prevent tigase to log "INFO" events to logs?

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam almost 5 years ago

Andrzej: do you think we can change log level for this message to something like FINE[ER|EST]?

Wojciech: do you remember how to set logging on per package level, so we can adjust this to reduce logging just from the BoshSession?

You can try this in your init.properties file:

basic-conf/logging/tigase.server.bosh.BoshSession.level=WARNING

This should reduce logging from this component to WARNINGs and SEVERE only.

Let me know if this worked.

Added by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 5 years ago

I think we can change this log level as this situation is somehow expected, so I would think about changed logging level of this message to FINER.

Added by David Leder almost 5 years ago

I actually have the following setting in the init.properties:

basic-conf/logging/tigase.server.level=ERROR

Isn't this sufficient to not log the INFO sections?

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam almost 5 years ago

I am afraid ERROR is not a valid level name. Here is a list of valid log levels: http://docs.oracle.com/javase/7/docs/api/java/util/logging/Level.html

    (1-6/6)