Project

General

Profile

Ubuntu Tigase Server Login Error

raghul ram
Added over 4 years ago

I tried setting up the Tigase server tigase-server-5.2.0-b3447 in Ubuntu with

MySql DB. I can start the server without any issues, but when i tried

connecting the server using any XMPP client(PSI, Empathy, Pidgin), the Client

throws the error -

There was an Error communicating with the server. Details: Authentication

error:Unable to login

I had cross checked my DB properties and is fine(the user and Password)

I tried setting up with Derby DB, and setup with Windows7, but never

succeeded .

Windows Error -

There was a Error Communicating with Server. Details - Connection : Unable to

connect to Server

init.properties

--comp-class-1 = tigase.muc.MUCComponent

--virt-hosts = localhost

--user-db-uri = jdbc:mysql://localhost/tigasedb?user=root&password=MYSQL123

--user-db = mysql

--admins = admin@localhost

--comp-name-6 = message-archive

--comp-name-5 = rest

--comp-name-4 = stun

--comp-name-3 = proxy

config-type = --gen-config-def

--comp-name-2 = pubsub

--comp-name-1 = muc

--cluster-mode = false

--sm-plugins = +message-archive-xep-0136,-jabber:iq:auth,-urn:ietf:params:xml:ns:xmpp-sasl,-urn:ietf:params:xml:ns:xmpp-bind,-urn:ietf:params:xml:ns:xmpp-session,+jabber:iq:register,+jabber:iq:roster,+presence,-jabber:iq:privacy,-jabber:iq:version,-http://jabber.org/protocol/stats,-starttls,-msgoffline,-vcard-temp,-http://jabber.org/protocol/commands,-jabber:iq:private,-urn:xmpp:ping,-basic-filter,-domain-filter,-pep,-zlib

--comp-class-6 = tigase.archive.MessageArchiveComponent

--debug = server,db

--comp-class-5 = tigase.http.rest.RestMessageReceiver

--comp-class-4 = tigase.stun.StunComponent

--comp-class-3 = tigase.socks5.Socks5ProxyComponent

--comp-class-2 = tigase.pubsub.PubSubComponent

tigase.conf

#osgiEnabled=(true|false)

#osgiEnabled=false

OSGI=false

ENC="-Dfile.encoding=UTF-8 -Dsun.jnu.encoding=UTF-8"

DRV="-Djdbc.drivers=com.mysql.jdbc.Driver:org.postgresql.Driver:org.apache.derby.jdbc.EmbeddedDriver"

#GC="-XX:+UseBiasedLocking -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:ParallelCMSThreads=2 -XX:-ReduceInitialCardMarks"

#EX="-XX:+OptimizeStringConcat -XX:+DoEscapeAnalysis -XX:+UseNUMA"

JAVA_HOME="/usr/lib/jvm/java-7-openjdk-amd64"

CLASSPATH=""

JAVA_OPTIONS="${GC} ${EX} ${ENC} ${DRV} -server -Xms100M -Xmx200M -XX:PermSize=32m -XX:MaxPermSize=256m -XX:MaxDirectMemorySize=128m "

TIGASE_CONFIG="etc/tigase.xml"

TIGASE_OPTIONS=" --property-file etc/init.properties "

Attached the Error Log file

error.txt (46.1 KB) error.txt

Replies (3)

Added by Wojciech Kapcia TigaseTeam over 4 years ago

  • please avoid using localhost as VHost (e.g. @--admins = admin@localhost@);

  • please provide server logs as well as client XML log from the time of the login;

Added by raghul ram over 4 years ago

Thanks for the reponse Wojciech Kapcia,

Running Desktop PSI App and Tigase Server in same machine is not advisable??

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam over 4 years ago

raghul ram wrote:

Thanks for the reponse Wojciech Kapcia,

Running Desktop PSI App and Tigase Server in same machine is not advisable??

It is OK for the development machine. There are no problems with Psi and Tigase on the same machine. The problems you can have are actually related to using localhost as the virtual host. However, for the development machine it still should be OK.

The error you get comes from the fact that you have disabled jabber:iq:auth plugin in your Tigase configuration but at the same time you try to use non-SASL (jabber:iq:auth) mechanism for user login. Hence the error. You actually disabled SASL authentication as well, so you will not be able to login at all. I suggest you enable these plugins in Tigase in order to allow your client to authenticate.

    (1-3/3)