Project

General

Profile

Could not connect to tigase server via PSI client or Adium

sashi kumar
Added almost 5 years ago

I have installed the tigase server and bind it with the mysql database.The server starts properly without any error.But when i connect to the server via PSI or Adium client i get the following message :

"There was an error communicating with the server. Details: Authentication error: Not authorized" . I have attached the log file and the init.properties.


Replies (4)

Added by Wojciech Kapcia TigaseTeam almost 5 years ago

Are you sure server is up and running? From the attached tigase-console.log it looks like it's not:

STARTED Tigase Mon Jul  7 21:14:40 IST 2014
sh: /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/bin/java: No such file or directory
sh: line 0: exec: /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/bin/java: cannot execute: No such file or directory
STOPPED Mon Jul  7 21:24:07 IST 2014
STARTED Tigase Mon Jul  7 21:24:10 IST 2014
sh: /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/bin/java: No such file or directory
sh: line 0: exec: /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/bin/java: cannot execute: No such file or directory

Added by sashi kumar almost 5 years ago

Thanks for the reply .

Actually i am using a MacOs.I use java 1.8 version. I have attached the log .I have reinstalled the server still i face the same issue .

Added by Wojciech Kapcia TigaseTeam almost 5 years ago

Which Tigase version do you try to use? Do you require OSGi mode? if not - please disable it in etc/tigase.conf

Added by Andrzej Wójcik IoT 1 CloudTigaseTeam almost 5 years ago

In logs you attached a see a lot of:

Unsupported major.minor version 51.0

which means you are trying to start Tigase XMPP Server with JDK older than JDK7 which is required. Please check if java used to start Tigase XMPP Server is in proper version.

    (1-4/4)