Project

General

Profile

Error compiling tigase server

Ganesh Krishnan
Added over 4 years ago

I have errors compiling the server pulled from the repo

[INFO] Compiling 508 source files to /home/spyder/developers/tigase-server/target/classes

[INFO] -------------------------------------------------------------

[ERROR] COMPILATION ERROR :

[INFO] -------------------------------------------------------------

[ERROR] /home/spyder/developers/tigase-server/src/main/java/tigase/vhosts/VHostItem.java:[49,18] error: cannot find symbol

[ERROR] symbol: class StringUtilities

location: package tigase.util

/home/spyder/developers/tigase-server/src/main/java/tigase/net/IOUtil.java:[30,17] DirectBuffer is internal proprietary API and may be removed in a future release

[ERROR] /home/spyder/developers/tigase-server/src/main/java/tigase/xmpp/impl/DomainFilter.java:[38,18] error: cannot find symbol

[ERROR] symbol: class StringUtilities

location: package tigase.util

/home/spyder/developers/tigase-server/src/main/java/tigase/vhosts/VHostItem.java:[562,27] error: cannot find symbol

[ERROR] symbol: variable StringUtilities

location: class VHostItem

Java 1.7 on Ubuntu 14

Any suggestions?


Replies (3)

Added by Ganesh Krishnan over 4 years ago

tigase.util.StringUtilities has not been checked in by the tigase devs. Moving to previous commit solves this problem

Added by Wojciech Kapcia TigaseTeam over 4 years ago

Ganesh Krishnan wrote:

tigase.util.StringUtilities has not been checked in by the tigase devs. Moving to previous commit solves this problem

It has been commited to the repository, simply not to tigase-server one. Please check that you have all dependencies up to date, including tigase-utils We are using jenkins to build all artifacts and deploy them to maven repository, however this is done on the nightly basis and you simply pulled tigase-utils artifact from the day before while trying to build latest sources of the server. Everything builds just fine: tigase-server at jenkins

    (1-3/3)