Project

General

Profile

Does AMP condition expire_at work on 5.2.3?

Natale Vinto
Added about 4 years ago

Hello,

I found out that on latest Tigase 5.2.3-b3470 this AMP Rule for time sensitive messaging is not working and messages are delivered even if expired:

         <rule action='error' condition='expire-at' value='2014-01-01T12:30:00Z'/>

The same rule is working on a 5.3.0 snapshot so the message is not delivered, is it normal for the 5.2.3 this misbehaviour?


Replies (4)

Added by Wojciech Kapcia TigaseTeam about 4 years ago

It was a bug - vide #1908

Added by Natale Vinto about 4 years ago

I cannot retrieve it from tracking https://projects.tigase.org/issues/1908 got me 403. Does it mean that it will be fixed in the 5.2.3 version?

Another question: supposing to continue working with 5.3.0, have I to switch to Tigase 7 version in order to stay in a development version?

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam about 4 years ago

Natale Vinto wrote:

I cannot retrieve it from tracking https://projects.tigase.org/issues/1908 got me 403. Does it mean that it will be fixed in the 5.2.3 version?

We are sorry, the bug ticket is in protected area, not accessible without permission. Anyway, the bug has been fixed and the fix is available in the recent development version.

Another question: supposing to continue working with 5.3.0, have I to switch to Tigase 7 version in order to stay in a development version?

Yes, next version we are going to release is 7.0.0 (not the 5.3.0). So please update to branch 7 for recent updates. We expect to publish final for the 7 by the end of the Jan 2015.

Added by Natale Vinto about 4 years ago

ok thanks

    (1-4/4)