Project

General

Profile

login error tigase server 7.0

liu zeyuan
Added about 4 years ago

please help me! as I have ever used the version 5.2.x ,I had two problems

first:

 with cluster I had recived twice same message -->https://projects.tigase.org/boards/4/topics/4190

second it is like this:

https://projects.tigase.org/boards/4/topics/2105

and then

I used tigase sever 7.0 nightly build ,2015-02-05 or 2015-01-04,

when first install successfully,I used spark and resgisted users jid:1@xcloud with password:1 successfuly

but failed to login with this error:

tigase.auth.XmppSaslException: PLAIN: 1 is not authorized to act as 1
    at tigase.auth.mechanisms.SaslPLAIN.evaluateResponse(SaslPLAIN.java:74)
    at tigase.xmpp.impl.SaslAuth.process(SaslAuth.java:277)
    at tigase.server.xmppsession.SessionManager$ProcessorWorkerThread.process(SessionManager.java:2427)
    at tigase.util.WorkerThread.run(WorkerThread.java:128)

ini.properties:

config-type=--gen-config-def
--admins=admin@xcloud
--virt-hosts = xcloud
--debug=server,xmpp,io
--user-db=mysql
--user-db-uri=jdbc:mysql://localhost:3306/tigasedb?user=root&password=root&useUnicode=true&characterEncoding=UTF-8&autoCreateUser=true
--comp-name-1=http
--comp-class-1=tigase.http.HttpMessageReceiver

Replies (7)

Added by Wojciech Kapcia TigaseTeam about 4 years ago

liu zeyuan wrote:

please help me! as I have ever used the version 5.2.x ,I had two problems

first:

 with cluster I had recived twice same message -->https://projects.tigase.org/boards/4/topics/4190

Please stick to the original threads, no need to create subsequent threads for the same issues.

As for the linked one - it was replied to already with the answer.

second it is like this:

https://projects.tigase.org/boards/4/topics/2105

Same as above.

I used tigase sever 7.0 nightly build ,2015-02-05 or 2015-01-04,

when first install successfully,I used spark and resgisted users jid:1@xcloud with password:1 successfuly

but failed to login with this error:

Have you registered the user with JID (not only name)? Please verify that you have user 1@xcloud in tig_users table.

Added by liu zeyuan about 4 years ago

yes I'm sure :

2015-02-06 17:04:07.046 [in_24-sess-man]   XMPPProcessor.canHandle()          FINEST:   XMPPProcessorIfc: BindResource (urn:ietf:params:xml:ns:xmpp-bind)
 Request: from=c2s@liuzeyuandemacbook-pro.local/127.0.0.1_5222_127.0.0.1_54925, to=sess-man@liuzeyuandemacbook-pro.local, DATA=<auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN">MQAxADE=</auth>, SIZE=80, XMLNS=urn:ietf:params:xml:ns:xmpp-sasl, PRIORITY=NORMAL, PERMISSION=NONE, TYPE=null, conn: XMPPResourceConnection=[user_jid=null, packets=2, connectioId=c2s@liuzeyuandemacbook-pro.local/127.0.0.1_5222_127.0.0.1_54925, domain=xcloud, authState=NOT_AUTHORIZED, isAnon=false, isTmp=false], authorization: null
2015-02-06 17:04:07.046 [in_24-sess-man]   XMPPProcessor.canHandle()          FINEST:   XMPPProcessorIfc: MessageCarbons (message-carbons)
 Request: from=c2s@liuzeyuandemacbook-pro.local/127.0.0.1_5222_127.0.0.1_54925, to=sess-man@liuzeyuandemacbook-pro.local, DATA=<auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN">MQAxADE=</auth>, SIZE=80, XMLNS=urn:ietf:params:xml:ns:xmpp-sasl, PRIORITY=NORMAL, PERMISSION=NONE, TYPE=null, conn: XMPPResourceConnection=[user_jid=null, packets=2, connectioId=c2s@liuzeyuandemacbook-pro.local/127.0.0.1_5222_127.0.0.1_54925, domain=xcloud, authState=NOT_AUTHORIZED, isAnon=false, isTmp=false], authorization: null
2015-02-06 17:04:07.046 [in_24-sess-man]   XMPPProcessor.canHandle()          FINEST:   XMPPProcessorIfc: JabberIqPrivate (jabber:iq:private)
 Request: from=c2s@liuzeyuandemacbook-pro.local/127.0.0.1_5222_127.0.0.1_54925, to=sess-man@liuzeyuandemacbook-pro.local, DATA=<auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN">MQAxADE=</auth>, SIZE=80, XMLNS=urn:ietf:params:xml:ns:xmpp-sasl, PRIORITY=NORMAL, PERMISSION=NONE, TYPE=null, conn: XMPPResourceConnection=[user_jid=null, packets=2, connectioId=c2s@liuzeyuandemacbook-pro.local/127.0.0.1_5222_127.0.0.1_54925, domain=xcloud, authState=NOT_AUTHORIZED, isAnon=false, isTmp=false], authorization: null
2015-02-06 17:04:07.046 [in_24-sess-man]   XMPPProcessor.canHandle()          FINEST:   XMPPProcessorIfc: JabberIqAuth (jabber:iq:auth)
 Request: from=c2s@liuzeyuandemacbook-pro.local/127.0.0.1_5222_127.0.0.1_54925, to=sess-man@liuzeyuandemacbook-pro.local, DATA=<auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN">MQAxADE=</auth>, SIZE=80, XMLNS=urn:ietf:params:xml:ns:xmpp-sasl, PRIORITY=NORMAL, PERMISSION=NONE, TYPE=null, conn: XMPPResourceConnection=[user_jid=null, packets=2, connectioId=c2s@liuzeyuandemacbook-pro.local/127.0.0.1_5222_127.0.0.1_54925, domain=xcloud, authState=NOT_AUTHORIZED, isAnon=false, isTmp=false], authorization: null
2015-02-06 17:04:07.047 [in_24-sess-man]   DomainFilter.filter()              FINEST:   Filtering (packet): from=c2s@liuzeyuandemacbook-pro.local/127.0.0.1_5222_127.0.0.1_54925, to=sess-man@liuzeyuandemacbook-pro.local, DATA=<auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN">MQAxADE=</auth>, SIZE=80, XMLNS=urn:ietf:params:xml:ns:xmpp-sasl, PRIORITY=NORMAL, PERMISSION=NONE, TYPE=null
2015-02-06 17:04:07.047 [in_24-sess-man]   SessionManager.processPacket()     FINEST:   Packet processed by: [urn:ietf:params:xml:ns:xmpp-sasl]
2015-02-06 17:04:07.050 [urn:ietf:params:xml:ns:xmpp-sasl Queue Worker 0]  SaslAuth.process()  FINER: SASL unsuccessful
tigase.auth.XmppSaslException: PLAIN: 1 is not authorized to act as 1
    at tigase.auth.mechanisms.SaslPLAIN.evaluateResponse(SaslPLAIN.java:74)
    at tigase.xmpp.impl.SaslAuth.process(SaslAuth.java:277)
    at tigase.server.xmppsession.SessionManager$ProcessorWorkerThread.process(SessionManager.java:2427)
    at tigase.util.WorkerThread.run(WorkerThread.java:128)
2015-02-06 17:04:07.051 [urn:ietf:params:xml:ns:xmpp-sasl Queue Worker 0]  DomainFilter.filter()  FINEST: Filtering (packet): from=c2s@liuzeyuandemacbook-pro.local/127.0.0.1_5222_127.0.0.1_54925, to=sess-man@liuzeyuandemacbook-pro.local, DATA=<auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN">MQAxADE=</auth>, SIZE=80, XMLNS=urn:ietf:params:xml:ns:xmpp-sasl, PRIORITY=NORMAL, PERMISSION=NONE, TYPE=null
2015-02-06 17:04:07.051 [urn:ietf:params:xml:ns:xmpp-sasl Queue Worker 0]  DomainFilter.getDomains()  FINEST: Domains read from user session: null for VHost: Domain: xcloud, enabled: true, anonym: true, register: true, maxusers: 0, tls: false, s2sSecret: 0b13d070-678b-4fe8-bf7e-880c0abae9a5, domainFilter: ALL, domainFilterDomains: null, c2sPortsAllowed: null, saslAllowedMechanisms: null

Added by Wojciech Kapcia TigaseTeam about 4 years ago

it looks like spark is sending 1:1:1 during SASL while it should send either :1:1 (without authz@) or @1@xcloud:1:1 (with JID as @authz@).

Added by liu zeyuan about 4 years ago

with the old version(5.2.x),spark works well, and I don't know how to modify spark to send 1@xcloud:1:1 (with JID as authz) :)

Added by liu zeyuan about 4 years ago

I also find asmack have same error

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam about 4 years ago

As far as I know both Spark and asmack is created by the same developer, so they both can have the same problem.

Avatar?id=6098&size=32x32

Added by Bartosz Małkowski TigaseTeam about 4 years ago

SASL plain message has structure:

[authzid] UTF8NUL authcid UTF8NUL passwd

authzid:

In the case of client-to-server communication, the value of an authorization identity MUST be a bare JID (localpart@domainpart) rather than a full JID ().

authcid:

authentication identity used in the context of such mechanisms is a "simple user name"

Both quotations from RFC-6120

    (1-7/7)