Project

General

Profile

Tigase 5.1.0 support of RFC 6120

Geoffrey Hamamoto
Added almost 4 years ago

Just a quick question. Did version 5.1.0 support RFC 6120?

Thank you.


Replies (6)

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam almost 4 years ago

Differences between RFC-6120 and RFC-3920 were very minimal and for sure Tigase is/was compatible with the older RFC. All new versions should be also compatible with the more recent RFC, however, we always try to preserve backward compatibility and not change behavior from one version to another in default setup. Maybe you could specify what exactly you have in mind I would be able to help you better.

Do you have any specific RFC section or requirement in mind?

Added by Geoffrey Hamamoto almost 4 years ago

Hi Artur,

I see that the newest releases of Tigase have implemented RFC 6120. So was wanting to know if 5.1.0 also implemented 6120. There are times when we need to quickly determine if a certain functionality is supported so it is helpful to know which RFC is officially supported.

Thanks!

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam almost 4 years ago

Ah, ok. We have a list of supported stuff by our software online: http://www.tigase.net/server-features If you click on selected feature you can get more details about it, such as the Tigase software version it is supported from: http://www.tigase.net/content/xmpp-core-0

It may not be up to date and some new features and additions might be missing but the information that is already there is accurate.

Added by Geoffrey Hamamoto almost 4 years ago

Thanks for the info Artur I see that RFC 6120 has been supported since 5.0.0. Do you know if multiple streams over a single connection was supported in 5.1.0?

This can be found here:

https://tools.ietf.org/html/rfc6120#section-4.5

...

Multiple streams over two or more TCP connections, where each

  stream is separately secured

....

Thanks!

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam almost 4 years ago

Yes, this is supported for s2s connections, however, as far as I remember we added support for this in version 5.2.x.

Added by Geoffrey Hamamoto almost 4 years ago

Artur, thank you for taking the time to answer these questions.

    (1-6/6)