Project

General

Profile

Issue with git clone

Wenjun Che
Added about 5 years ago

Hello

I am having the following issue:

git clone https://repository.tigase.org/git/tigase-server.git

Cloning into 'tigase-server'...

error: Unrecognized Object Identifier. while accessing https://repository.tigase.org/git/tigase-server.git/info/refs?service=git-upload-pack

fatal: HTTP request failed

Thanks


Replies (5)

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam about 5 years ago

Maybe our SSL certificate is not recognized by your git command, try this:

GIT_SSL_NO_VERIFY=true git clone https://repository.tigase.org/git/tigase-server.git tigase-server

Added by Wenjun Che about 5 years ago

Hello Artur

Setting GIT_SSL_NO_VERIFY fixed the issue. Also, older version of git works too.

I have another question: the source requires jdk1.7 to build and run. Last week I downloaded binary of 5.2.0-beta3-b3269 and it works fine with jdk1.6. I am just curious why the binary does not require 1.7.

Thanks

Added by Wojciech Kapcia TigaseTeam about 5 years ago

Actually beta3 was the first release that required JDK7, please read announcement

Switched JDK compatibility to JDK7. Number of issues in Tigase server were related to bugs in JDK6 and patching them and creating workarounds was taking up resources. Therefore we decided to switch over to JDK7. Right now Tigase on JDK7 is under extensive tests. Please let us know if you find any issues.

Added by Wenjun Che about 5 years ago

Thanks for the info.

FYI: I ran repository.tigase.org through few SSL checkers (such as https://www.geocerts.com/ssl_checker). All of them complain about incomplete certificate chain, which is probably cause of the git issue I had earlier.

Added by Wojciech Kapcia TigaseTeam about 5 years ago

Thanks for pointing that out - I've updated configuration of repository.tigase.org to include full certification chain - this should resolve the problem and ignoring ssl verification should not be needed anymore.

    (1-5/5)