Project

General

Profile

./tigase.sh: /bin/bash^M: bad interpreter: No such file or directory ?

peirong jiang
Added about 3 years ago

execute this code on centos6:

/home/kefu/tigase/im-server-7.0.2/scripts/tigase.sh restart /home/kefu/tigase/im-server-7.0.2/etc/tigase.conf

throw the following errors:

/home/kefu/tigase/im-server-7.0.2/scripts/tigase.sh restart /home/kefu/tigase/im-server-7.0.2/etc/tigase.conf

-bash: /home/kefu/tigase/im-server-7.0.2/scripts/tigase.sh: /bin/bashM: bad interpreter: No such file or directory

why? how can i resolve it?

error.jpg (18.9 KB) error.jpg

Replies (3)

Added by Wojciech Kapcia TigaseTeam about 3 years ago

Have you edited this file? Have you changed line endings?

Please try running:

$ dos2unix /home/kefu/tigase/im-server-7.0.2/scripts/tigase.sh

Added by peirong jiang about 3 years ago

tkx,now it is runing!

but I got the another problem:

tigase throws:

Couldn't obtain user repository for domain: vhost-manager, not even default one!

2015-12-30 21:26:59.668 [scheduler_pool-10-thread-1-s2s] ConnectionManager$1.run() FINE: Reconnecting service for component: s2s, to remote host: localhost on port: 5269

2015-12-30 21:26:59.674 [scheduler_pool-3-thread-1-bosh] ConnectionManager$1.run() FINE: Reconnecting service for component: bosh, to remote host: localhost on port: 5280

2015-12-30 21:26:59.680 [scheduler_pool-13-thread-1-ws2s] ConnectionManager$1.run() FINE: Reconnecting service for component: ws2s, to remote host: localhost on port: 5290

2015-12-30 21:27:56.298 [hostnames] UserRepositoryMDImpl.getData() WARNING: Couldn't obtain user repository for domain: vhost-manager, not even default one!

2015-12-30 21:28:56.297 [hostnames] UserRepositoryMDImpl.getData() WARNING: Couldn't obtain user repository for domain: vhost-manager, not even default one!

2015-12-30 21:29:56.297 [hostnames] UserRepositoryMDImpl.getData() WARNING: Couldn't obtain user repository for domain: vhost-manager, not even default one!

2015-12-30 21:30:56.297 [hostnames] UserRepositoryMDImpl.getData() WARNING: Couldn't obtain user repository for domain: vhost-manager, not even default one!

and my xmpp client can't log in, why it like that? How can i resolve this problem?

Added by Daniel Wisnewski IoT 1 Cloud about 3 years ago

Since Tigase cannot connect to the database, it can't authenticate users. There may be something wrong with your database settings (passwords, or URI). Can you share settings and setup?

    (1-3/3)