Project

General

Profile

Tigase randomly shutdown after running for 1-3 days

Zen T
Added almost 3 years ago

My Setup:

Tigase 5.2.0

Oracle Java 8

Ubuntu 14.04

Running htop while tigase is running gives me :

Mem: 400/588MB (this is a server for small amount of users)

CPU: usually around 2% to 30%

In tigase.conf, I set the memory like this according to some forum posts, still it is shutting down randomly:

JAVA_OPTIONS="${GC} ${EX} ${ENC} ${DRV} -server -Xms300M -Xmx300M -XX:PermSize=32m -XX:MaxPermSize=256m -XX:MaxDirectMemorySize=128m "

Few weeks ago, I upgraded Oracle Java 7 to Oracle Java 8. Then I started to experience this problem where tigase would suddenly shutdown after running for 1-3 days, without any error log.

Previous setup was fine and running for a year without problem (only difference is Oracle Java 7, others same as above). If not for the TLS security issue in Google Chrome, I wouldn't have to upgrade to Java 8.

Anyway, in the tigase-console.log I saw a lot of these infitite loops warning.

2016-03-08 22:13:17.000 [in_1-c2s] TLSIO.writeBuff() WARNING: Infinite loop detected in writeBuff(buff) TLS code, tlsWrapper.getStatus(): NEED_READ

2016-03-08 22:47:20.761 [in_2-c2s] TLSIO.writeBuff() WARNING: Infinite loop detected in writeBuff(buff) TLS code, tlsWrapper.getStatus(): NEED_READ

In tigase.log.0, i just saw a lot of "Created server TLSWrapper. Protocols:[...." and some "Authentication timeout expired". There are no big errors.

Any idea?

Thanks!


Replies (1)

Added by Wojciech Kapcia TigaseTeam almost 3 years ago

Please check logs/tigase-console.log for more details. How do you check memory utilization?

    (1-1/1)