Project

General

Profile

Build errors for tigase-server

Sam Yu
Added over 5 years ago

Dears,

When I use MyEclipse for building the tigase-server project(lastest version), get the building error below:

Build errors for tigase-server; org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.codehaus.gmaven:gmaven-plugin:1.5:execute (gitver) on project tigase-server: java.io.IOException: Cannot run program git CreateProcess error=2, ϵͳÕҲ»µ½ָ¶

I am a newbie on tigase project, and hope I could get your help. Thanks!


Replies (14)

Added by Wojciech Kapcia TigaseTeam over 5 years ago

Please install @git@.

Added by Sam Yu over 5 years ago

I have installed git.

C:\Users\lenovo>git --version

git version 1.8.4.msysgit.0

Added by Wojciech Kapcia TigaseTeam over 5 years ago

Did it resolve the issue?

Added by Sam Yu over 5 years ago

Hi Wojciech Kapcia:

I have resolve this issue after intalling the git plugin in MyEclipse.

hi cheng huang:

I am following the guide you mentioned above and get the below error when run ./scripts/installer-generate.sh

*/bin/sh: 1: installer/izpack.patched/utils/wrappers/izpack2exe/7za: not found

Traceback (most recent call last):

File "installer/izpack.patched/utils/wrappers/izpack2exe/izpack2exe.py", line 116, in

main()

File "installer/izpack.patched/utils/wrappers/izpack2exe/izpack2exe.py", line 113, in main

create_exe(parse_options())

File "installer/izpack.patched/utils/wrappers/izpack2exe/izpack2exe.py", line 96, in create_exe

in_file = open(f, 'rb')

IOError: [Errno 2] No such file or directory: 'installer.7z'*

I have installed git, python2, docutils, LaTeX and p7zip.

Do you or anybody know how I could resolve this error? Thanks a lot!

Added by Wojciech Kapcia TigaseTeam over 5 years ago

Hi Sam Yu,

Which version are you trying to build (origin/master)? Under what operating system?

Added by Sam Yu over 5 years ago

Hi Wojciech,

Version is tigase-server-5.2.0-beta3-b3269.

OS info:

root@AY131031182021Z:~# uname -a

Linux AY131031182021Z 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

root@AY131031182021Z:~# cat /proc/version

Linux version 3.2.0-29-generic (buildd@allspice) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012

root@AY131031182021Z:~# cat /etc/issue

Ubuntu 12.04.1 LTS \n \l

Added by Wojciech Kapcia TigaseTeam over 5 years ago

Hm, have you run ./scripts/installer-prepare.sh first? is the file installer/izpack.patched/utils/wrappers/izpack2exe/7za present in mentioned path?

Added by Sam Yu over 5 years ago

Hi Wojciech,

I run ./scripts/installer-prepare.sh before ./scripts/installer-generate.sh.

And 7za is present in metioned path:

root@AY131031182021Z:/home/tigase-server/installer/izpack.patched/utils/wrappers/izpack2exe# ls

7za app.ico LICENSE.7zip.txt NOTICE upx.exe

7za.exe exe.ico LICENSE.txt setup.py

7zS.sfx izpack2exe.py LICENSE.upx.txt upx

Added by Wojciech Kapcia TigaseTeam over 5 years ago

Ah, it's not about missing 7za binary; do you have any working installer in pack/ directory (i.e. .jar file)? it seems that actual generation of the installer by IzPack is failing which result in missing @installer.7z@; could you share full console output of both scripts?

Added by Jose Olcese over 5 years ago

Any update on this? I'm facing the same problem.

Thanks

Added by Wojciech Kapcia TigaseTeam over 5 years ago

@Jose

Which one exactly? There were several issues in this thread. If it's related to supposedly missing '7za' binary then please read my previous message and provide script console update.

Added by Jose Olcese over 5 years ago

Hi Wojciech,

The problem is related to missing '7za' binary (which actually exists on the location that's failing)

installer-prepare.sh

https://gist.github.com/jolcese/7577366/raw/517fe950dabfa41313b6c7ed46cd76c14dfa4b06/installer-prepare.sh

installer-generate.sh

https://gist.github.com/jolcese/7577329/raw/81f058556ff1383cd15cb3342aaf7765eb4a8030/installer-generate.sh

Thanks!

Jose

Added by Wojciech Kapcia TigaseTeam over 5 years ago

A few questions:

  • does setting JAVA_HOME environment variable helps?

  • are you able to run installer file /home/ubuntu/tigase-server/./pack/tigase-server-5.2.0-SNAPSHOT-b3371.jar ?

  • which ubuntu/python version do you have and use?

  • can you run on it's own following command:

installer/izpack.patched/utils/wrappers/izpack2exe/izpack2exe.py --file=./pack/tigase-server-5.2.0-SNAPSHOT-b3371.jar --no-upx --output=./pack/tigase-server-5.2.0-SNAPSHOT-b3371.exe

    (1-14/14)