Project

General

Profile

Stream management with presence packet

flame fire
Added 4 months ago

Hello!
I hava a question about stream management with presence packet.
My tigease version is 7.1.0.
As i opened the stream management and the xmpp clients under weak network ,all message packets can be treated as offline messages.
but the presence packet does not work.
when the client "ffe1@localhost" is under the weak network,and I send the presence packet to him like this :

    <presence type="subscribe" to="ffe1@localhost">
    <x>hello,could u make friend with me?</x>
    </presence>

,this packet can not be offline message and put into msg_history table.

if the "ffe1@localhost"client obviously logout ,then the packet would be offline message and put into msg_history table.


Replies (3)

Added by Wojciech Kapcia 4 months ago

What tools are you using? Any additional plugins enabled? SM shouldn't differentiate on packet type, but if the connection was lost then the re-delivery may be delayed.

Added by flame fire 4 months ago

Here is my init.property:

config-type=--gen-config-def
--virt-hosts=mline-test.9yiwu.com,mline.9yiwu.com
--admins=admin@mline-test.9yiwu.com,pubsub.mline-test.9yiwu.com,http@mline-hk-test-core01,admin@mline.9yiwu.com,pubsub.mline.9yiwu.com
--cluster-mode=true
--cluster-connect-all = true
#--cluster-nodes=mline-hk-test-core01
--cluster-nodes=mline-hk-test-core01,mline-hk-test-node01

--cm-ht-traffic-throttling=xmpp:25k:0:disc,bin:200m:0:disc

--debug=server

--user-db-uri=jdbc:mysql://localhost/tigasedb?user=tigase&password=tigase&autoReconnect=true&useUnicode=true

--sm-plugins=+jabber\:iq\:auth,+urn\:ietf\:params\:xml\:ns\:xmpp-sasl,+urn\:ietf\:params\:xml\:ns\:xmpp-bind,+urn\:ietf\:params\:xml\:ns\:xmpp-session,-jabber\:iq\:register,+jabber\:iq\:roster,+presence-state,+presence-subscription,+basic-filter,+domain-filter,-jabber\:iq\:privacy,-jabber\:iq\:version,+http\://jabber.org/protocol/stats,+starttls,-vcard-temp,+http\://jabber.org/protocol/commands,-jabber\:iq\:private,+urn\:xmpp\:ping,+pep,+zlib,+amp,-message-archive-xep-0136,+resource_manager,+token_manager,-msgoffline,msgoffline_manager,+session_manager

--comp-name-2=pubsub
--comp-class-2=tigase.pubsub.PubSubComponent

--comp-name-3=http
--comp-class-3=tigase.http.HttpMessageReceiver

http/setup/admin-credentials=admin:tigase

c2s/processors[s]=urn:xmpp:sm:3

http/rest/api-keys[s]=open_access

--vhost-tls-required=true
--vhost-anonymous-enabled=false
--vhost-register-enabled=false

c2s/urn\:xmpp\:sm\:3/max-resumption-timeout[I]=5
c2s/urn\:xmpp\:sm\:3/resumption-timeout[I]=5

is it any problem ?

Added by Wojciech Kapcia 4 months ago

--sm-plugins=+jabber\:iq\:auth,+urn\:ietf\:params\:xml\:ns\:xmpp-sasl,+urn\:ietf\:params\:xml\:ns\:xmpp-bind,+urn\:ietf\:params\:xml\:ns\:xmpp-session,-jabber\:iq\:register,+jabber\:iq\:roster,+presence-state,+presence-subscription,+basic-filter,+domain-filter,-jabber\:iq\:privacy,-jabber\:iq\:version,+http\://jabber.org/protocol/stats,+starttls,-vcard-temp,+http\://jabber.org/protocol/commands,-jabber\:iq\:private,+urn\:xmpp\:ping,+pep,+zlib,+amp,-message-archive-xep-0136,+resource_manager,+token_manager,-msgoffline,msgoffline_manager,+session_manager
  • majority of the plugins are enabled/disabled by default therefore you should only include the plugins which state you wan't to change (for example -message-archive-xep-0136,+resource_manager)
  • you have a couple of custom plugins (@+resource_manager,+token_manager,-msgoffline,msgoffline_manager,+session_manager) - can you make sure they are not interfering?

    (1-3/3)