Project

General

Profile

Tigase packages dependency change - server compilation version 4.x or later

Avatar?id=6023&size=32x32

Artur Hefczyc TigaseTeam
Added over 4 years ago

The dependency for Tigase Utils Package has changed. This is important for everybody who builds the Tigase server manually from sources using Ant tool. The Maven handles all the dependencies automatically and scripts have been updated.

Please keep reading for more details how to compile the server from sources in current SVN repositories.

If you have an old Tigase MUC or Tigase Extras package lying in the server/libs/ directory please remove it now. You have to update it too and copy it over to the server/libs/ directory after you completed steps below.

For all those who build the server from sources manually using Ant here is a short guide:

  1. Checkout all the sources first:
  2. Build the Tigase XMLTools and copy the jar file over to the utils and server libs/ directory
    • cd xmltools
    • ant clean jar-dist
    • cp jars/tigase-xmltools.jar ../utils/libs
    • cp jars/tigase-xmltools.jar ../server/libs
  3. Build the Tigase Utils and copy the jar file to the server libs/ directory
    • cd ../utils
    • ant clean jar-dist
    • cp jars/tigase-utils.jar ../server/libs
  4. Build the Tigase Server binary
    • cd ../server
    • ant clean jar-dist

 This is a very short guide but I hope it helps. If you have any problems, please let me know.

Addendum: starting with version 5.2.0 all libraries and jar files for the server are in jars/ directory; however with that version we strongly encourage to switch to maven build system as we are phasing out Ant - please follow guide Tigase XMPP Server 5.2.0 and later - compilation and generating distribution packages