Project

General

Profile

How to disable MUC hostory support?

Justin Posey
Added over 5 years ago

We have tried the following in init.properties, but it doesn't appear to work. Is there a way to effectively disable MUC history? Thank you!

muc/muc-max-history-size[I]=0
muc/history-db=memory

Replies (7)

Added by Justin Posey over 5 years ago

Ideally we would like the ability to have a no-op history provider.

(1)
Avatar?id=6098&size=32x32

Added by Bartosz Małkowski TigaseTeam over 5 years ago

In latest code from git you can use:

muc/history-db=none

Added by Justin Posey over 5 years ago

Thanks, Bartosz. I will try that.

(1)

Added by Tuan Son Phan over 5 years ago

I have installed 5.2 version. It seem not support that feature (disable history provider), right?

Regarding your lastest code in git, when will you release it?

Thank you.

(1)

Added by Justin Posey over 5 years ago

Hi Bartosz,

Would that be tigase:tigase-muc version 2.2.0-SNAPSHOT or 2.2.0-tigase-server-5.2.0-rc2?

Avatar?id=6023&size=32x32

Added by Artur Hefczyc TigaseTeam over 5 years ago

Tuan Son Phan wrote:

I have installed 5.2 version. It seem not support that feature (disable history provider), right?

You can try our nightly builds which based on the most recent code repository.

Regarding your lastest code in git, when will you release it?

Next version will be released 10 days after the last one was published. It will be either RC3 or final 5.2.0.

Added by Wojciech Kapcia TigaseTeam over 5 years ago

Justin Posey wrote:

Would that be tigase:tigase-muc version 2.2.0-SNAPSHOT or 2.2.0-tigase-server-5.2.0-rc2?

Yes, the fix made it to the rc2 release:

24/01/2014 09:23 am tigase-muc-2.2.0-tigase-server-5.2.0-rc2 release

24/01/2014 06:37 am add "none" history provider (muc/history-db=none)

    (1-7/7)