Project

General

Profile

can not configure MUC in Spark

Andrew Ceropan
Added almost 5 years ago

Hello,

I created MUC in Spark and configure it to be persistent. Tigase responsed it configured successfully. but when query later on the room still not configured , could you help on this?

If I use Psi then can configure properly.

Thanks in advance.

Andrew


Replies (2)

(1)
Avatar?id=6098&size=32x32

Added by Bartosz Małkowski TigaseTeam almost 5 years ago

I think you should commit configuration. Or accept current default configuration:

<iq from='crone1@shakespeare.lit/desktop'
    id='create1'
    to='coven@chat.shakespeare.lit'
    type='set'>
  <query xmlns='http://jabber.org/protocol/muc#owner'>
    <x xmlns='jabber:x:data' type='submit'/>
  </query>
</iq>

Added by Andrew Ceropan almost 5 years ago

This is the commit?

<iq id="KoSeO-124" to="goodroom@muc.www.gogogagakiki.biz" type="set">
  <query xmlns="http://jabber.org/protocol/muc#owner">
    <x xmlns="jabber:x:data" type="submit">
      <field var="muc#roomconfig_persistentroom" type="boolean">
        <value>1</value>
      </field>
      <field var="muc#roomconfig_publicroom" type="boolean">
        <value>1</value>
      </field>
      <field var="muc#roomconfig_moderatedroom" type="boolean">
        <value>0</value>
      </field>
      <field var="muc#roomconfig_membersonly" type="boolean">
        <value>0</value>
      </field>
      <field var="muc#roomconfig_passwordprotectedroom" type="boolean">
        <value>0</value>
      </field>
      <field var="muc#roomconfig_anonymity" type="list-single">
        <value>semianonymous</value>
      </field>
      <field var="muc#roomconfig_changesubject" type="boolean">
        <value>0</value>
      </field>
      <field var="muc#roomconfig_enablelogging" type="boolean">
        <value>0</value>
      </field>
      <field var="logging_format" type="list-single">
        <value>html</value>
      </field>
      <field var="muc#maxhistoryfetch" type="text-single">
        <value>50</value>
      </field>
      <field label="Natural-Language Room Name" var="muc#roomconfig_roomname" type="text-single">
        <value/>
      </field>
      <field label="Short Description of Room" var="muc#roomconfig_roomdesc" type="text-single">
        <value/>
      </field>
      <field label="Make Room Persistent?" var="muc#roomconfig_persistentroom" type="boolean">
        <value>0</value>
      </field>
      <field label="Make Room Publicly Searchable?" var="muc#roomconfig_publicroom" type="boolean">
        <value>1</value>
      </field>
      <field label="Make Room Moderated?" var="muc#roomconfig_moderatedroom" type="boolean">
        <value>0</value>
      </field>
      <field label="Make Room Members Only?" var="muc#roomconfig_membersonly" type="boolean">
        <value>0</value>
      </field>
      <field label="Password Required to Enter?" var="muc#roomconfig_passwordprotectedroom" type="boolean">
        <value>0</value>
      </field>
      <field label="Password" var="muc#roomconfig_roomsecret" type="text-single">
        <value/>
      </field>
      <field label="Room anonymity level:" var="muc#roomconfig_anonymity" type="list-single">
        <value>semianonymous</value>
        <option label="Non-Anonymous Room">
          <value>nonanonymous</value>
        </option>
        <option label="Semi-Anonymous Room">
          <value>semianonymous</value>
        </option>
        <option label="Fully-Anonymous Room">
          <value>fullanonymous</value>
        </option>
      </field>
      <field label="Allow Occupants to Change Subject?" var="muc#roomconfig_changesubject" type="boolean">
        <value>0</value>
      </field>
      <field label="Enable Public Logging?" var="muc#roomconfig_enablelogging" type="boolean">
        <value>0</value>
      </field>
      <field label="Logging format:" var="logging_format" type="list-single">
        <value>html</value>
        <option label="HTML">
          <value>html</value>
        </option>
        <option label="Plain text">
          <value>plain</value>
        </option>
      </field>
      <field label="Maximum Number of History Messages Returned by Room" var="muc#maxhistoryfetch" type="text-single">
        <value>50</value>
      </field>
    </x>
  </query>
</iq>

    (1-2/2)