Project

General

Profile

muc-max-history-size not working

Vinoth Rajendran
Added about 4 years ago

I have installed Tigase 5.2.3. and its init.properties file follows,

--comp-class-1 = tigase.muc.MUCComponent

--comp-class-6 = tigase.muc.MUCComponent

--comp-class-5 = tigase.muc.MUCComponent

--virt-hosts = 192.168.1.94

--user-db-uri = jdbc:mysql://localhost/tigasedb?user=root&password=root

--user-db = mysql

--admins = admin@192.168.1.94

--comp-name-4 = message-archive

--comp-name-3 = proxy

config-type = --gen-config-all

--comp-name-2 = pubsub

--comp-name-6 = conference

--comp-name-5 = channel

--comp-name-1 = muc

--cluster-mode = true

--sm-plugins = +message-archive-xep-0136

conference/default_room_config/conference#roomconfig_persistentroom=true

muc/default_room_config/muc#roomconfig_persistentroom=true

channel/default_room_config/channel#roomconfig_persistentroom=true

--debug = server, archive

--comp-class-4 = tigase.archive.MessageArchiveComponent

--comp-class-3 = tigase.socks5.Socks5ProxyComponent

--comp-class-2 = tigase.pubsub.PubSubComponent

--tigase.cache=true

muc/muc-max-history-size[I]=5

message-archive/archive-repo-uri=jdbc:mysql://localhost/tigasedb?user=root&password=root

#message-archive/auto=true

sess-man/plugins-conf/message-archive-xep-0136/required-store-method=message

sess-man/plugins-conf/message-archive-xep-0136/component-jid=message-archive@192.168.1.94

And my santza which I have sent to receive MUC chat history.

Response is I have received whole history of that room,

I don't want whole history because restricted only 5 messages at init.properties file(muc/muc-max-history-size[I]=5)


Replies (2)

Avatar?id=6098&size=32x32

Added by Bartosz Małkowski TigaseTeam about 4 years ago

muc-max-history-size parameter isn't implemented in current code.

    (1-2/2)