Project

General

Profile

Broadcast Message Not working

Vinoth Rajendran
Added about 4 years ago

I have installed Tigase 5.2.3. I want to do send message/notification to all user not from ad-hoc commands(see : http://xmpp.org/extensions/xep-0050.html#announce). Using a code to generate This stanza and sent to server. But I got response 404.

Stanza which I sent :

<iq from="54c24dc0a1bd2a7a09bddb72@192.168.1.94/tigase-5" to="192.168.1.94" type="set" id="announce-2" xml:lang="en"><command xmlns="http://jabber.org/protocol/commands" node="http://jabber.org/protocol/admin#announce" sessionid="announce:20040408T0337Z"><x xmlns="jabber:x:data" type="submit"><field type="hidden" var="FORM_TYPE"><value>http://jabber.org/protocol/admin</value></field><field var="announcement"><value>Attention! This service will be going down for</value><value>maintenance in 2 minutes. Please log off now!</value></field></x></command></iq>

Error Stanza :

<iq id="announce-2" xmlns="jabber:client" from="192.168.1.94" type="error" to="admin@192.168.1.94/tigase-5" xmlns:stream="http://etherx.jabber.org/streams"><command sessionid="announce:20040408T0337Z" xmlns="http://jabber.org/protocol/commands" node="http://jabber.org/protocol/admin#announce"><x xmlns="jabber:x:data" type="submit"><field var="FORM_TYPE" type="hidden"><value>http://jabber.org/protocol/admin</value></field><field var="announcement"><value>Attention! This service will be going down for</value><value>maintenance in 2 minutes. Please log off now!</value></field></x></command><error code="404" type="wait"><recipient-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/><text xml:lang="en" xmlns="urn:ietf:params:xml:ns:xmpp-stanzas">The recipient is no longer available.</text></error></iq>

What I missed out to get this error and nothing will be printed in log (tigase-console.log)file. Is there any option to print log(for debugging). I have tried adding a single line in (--debug = server,db, archive, xmpp.impl, xmpp) init.properties file. But It not working?.


Replies (2)

Added by Wojciech Kapcia TigaseTeam about 4 years ago

Vinoth Rajendran wrote:

When I sent following stanza to Tigase to send notification to all online users.

to='192.168.1.94'

How can do that?

You should address the command to sess-man@<domain> instead of plain @@.

(1)

Added by Vinoth Rajendran about 4 years ago

I need to send message/notifications from ad-hoc commands.

Here is my init.properties file,

--comp-class-1 = tigase.muc.MUCComponent

--comp-class-6 = tigase.muc.MUCComponent

--comp-class-5 = tigase.muc.MUCComponent

--virt-hosts = 192.168.1.94

--user-db-uri = jdbc:mysql://localhost/tigasedb?user=root&password=root

--user-db = mysql

--admins = admin@192.168.1.94

--comp-name-4 = message-archive

--comp-name-3 = proxy

config-type = --gen-config-all

--comp-name-2 = pubsub

--comp-name-6 = conference

--comp-name-5 = channel

--comp-name-1 = muc

--cluster-mode = true

--sm-plugins = +message-archive-xep-0136

#--comp-name-7=http

#--comp-class-7=tigase.http.HttpMessageReceiver

#rest/port=8080

#rest/use-local-server[B]=true

  1. To save group chat message.

conference/default_room_config/conference#roomconfig_persistentroom=true

muc/default_room_config/muc#roomconfig_persistentroom=true

channel/default_room_config/channel#roomconfig_persistentroom=true

--debug = server,db, archive, xmpp.impl, xmpp

--comp-class-4 = tigase.archive.MessageArchiveComponent

--comp-class-3 = tigase.socks5.Socks5ProxyComponent

--comp-class-2 = tigase.pubsub.PubSubComponent

  1. To Enabling typing notification for muc

conference/muc-allow-chat-states[B]=true

conference/message-filter-enabled[B]=false

muc/muc-allow-chat-states[B]=true

muc/muc-lock-new-room[B]=false

channel/muc-lock-new-room[B]=false

message-archive/archive-repo-uri=jdbc:mysql://localhost/tigasedb?user=root&password=root

What I want to do furthur?

    (1-2/2)