Project

General

Profile

Missing "id" in response message

thilo jith
Added about 4 years ago

XML has id along with this when sending message. The same id should get back in response as well. But I didn't get it back.This small issue leads to more bugs. Could anyone please help to resolve this?

<?xml version="1.0" encoding="UTF-8"?>
<body xmlns="http://jabber.org/protocol/httpbind" rid="3273271392" sid="36b73f6e-95d1-440a-ad21-70149edefacc">
    <message xmlns="jabber:client" to="54f591a9cc2ea4343753d0ae@conference.192.168.1.33" from="54edad3d27a2b026444ed8bc@192.168.1.33/converse.js-67557254" type="groupchat" id="1426678343856">
        <body>234234</body>
    </message>
</body>

The response as:

<?xml version="1.0" encoding="UTF-8"?>
<body xmlns="http://jabber.org/protocol/httpbind" xmlns:stream="http://etherx.jabber.org/streams" xmlns:xmpp="urn:xmpp:xbosh" ack="3273271392" xmpp:version="1.0" host="babuk-desktop" secure="true" from="192.168.1.33">
    <message xmlns="jabber:client" to="54edad3d27a2b026444ed8bc@192.168.1.33/converse.js-67557254" type="groupchat" from="54f591a9cc2ea4343753d0ae@conference.192.168.1.33/54edad3d27a2b026444ed8bc">
        <body>234234</body>
    </message>
</body>

Configuration:

--comp-class-1 = tigase.muc.MUCComponent
--comp-class-6 = tigase.muc.MUCComponent
--comp-class-5 = tigase.muc.MUCComponent
--virt-hosts = 192.168.1.33
--user-db-uri = jdbc:mysql://localhost/tigasedb?user=tigase&password=tigase
--user-db = mysql
--admins = admin@192.168.1.33
--comp-name-4 = message-archive
--comp-name-3 = proxy
config-type = --gen-config-def
--comp-name-2 = pubsub
--comp-name-6 = conference
--comp-name-5 = channel
--comp-name-1 = muc
--cluster-mode = false
--sm-plugins = +message-archive-xep-0136
--debug = server
--comp-class-4 = tigase.archive.MessageArchiveComponent
--comp-class-3 = tigase.socks5.Socks5ProxyComponent
--comp-class-2 = tigase.pubsub.PubSubComponent

# To save group chat message. 
conference/default_room_config/conference#roomconfig_persistentroom=true
muc/default_room_config/muc#roomconfig_persistentroom=true
channel/default_room_config/channel#roomconfig_persistentroom=true

--debug = server, archive
--comp-class-4 = tigase.archive.MessageArchiveComponent
--comp-class-3 = tigase.socks5.Socks5ProxyComponent
--comp-class-2 = tigase.pubsub.PubSubComponent

# To Enabling typing notification
conference/muc-allow-chat-states[B]=true
conference/message-filter-enabled[B]=false



conference/room-log-directory=/home/babuk/opsbus/opsbus/

message-archive/archive-repo-uri=jdbc:mysql://localhost/tigasedb?user=tigase&password=tigase

sess-man/plugins-conf/message-archive-xep-0136/required-store-method=message
sess-man/plugins-conf/message-archive-xep-0136/component-jid=message-archive@192.168.1.33

Log:

MessageRouter.processPacket()  FINEST:   1. Packet will be processed by: conference@babuk-desktop, from=sess-man@babuk-desktop, to=null, DATA=<message xmlns="jabber:client" to="54f591a9cc2ea4343753d0ae@conference.192.168.1.33" type="groupchat" from="54edad3d27a2b026444ed8bc@192.168.1.33/converse.js-67557254" id="1426676752240"><body>345</body></message>, SIZE=213, XMLNS=jabber:client, PRIORITY=NORMAL, PERMISSION=AUTH, TYPE=groupchat
2015-03-18 16:35:52.355 [in_4-message-router]  MessageRouter.processPacket()  FINEST:   Processing packet: from=null, to=null, DATA=<message to="54edad3d27a2b026444ed8bc@192.168.1.33/converse.js-67557254" type="groupchat" from="54f591a9cc2ea4343753d0ae@conference.192.168.1.33/54edad3d27a2b026444ed8bc" xmlns="jabber:client"><body>345</body></message>, SIZE=219, XMLNS=jabber:client, PRIORITY=NORMAL, PERMISSION=NONE, TYPE=groupchat

Replies (4)

Added by Wojciech Kapcia TigaseTeam about 4 years ago

thilo jith wrote:

XML has id along with this when sending message. The same id should get back in response as well. But I didn't get it back.This small issue leads to more bugs. Could anyone please help to resolve this?

Which Tigase version do you use? It was fixed in latest release.

Added by thilo jith about 4 years ago

Tigase version 5.2.3

(1)

Added by Wojciech Kapcia TigaseTeam about 4 years ago

Then as I said - please migrate to version 7.0.0 which has this issue addressed.

(1)

Added by thilo jith about 4 years ago

Thank you for your support.

    (1-4/4)