Project

General

Profile

Pubsub Component

Behnam Hatami
Added over 4 years ago

I have problem with Tigase 7.0.0 Snapshot.

I don't enable pubsub component first, then when i try to log into admin with psi, server enter infinite loop!

when I re enabled pubsub, the problem solved!


Replies (6)

(1)

Added by Wojciech Kapcia TigaseTeam over 4 years ago

Behnam Hatami wrote:

I have problem with Tigase 7.0.0 Snapshot.

I don't enable pubsub component first, then when i try to log into admin with psi, server enter infinite loop!

when I re enabled pubsub, the problem solved!

Could you be more specific? What do you mean 'infinite loop'? What does the log say?

Pubsub component on it's own should not influence Tigase in such way.

(1)

Added by Behnam Hatami over 4 years ago

As I mentioned, there isn't any special configuration.

I configured Tigase 7.0.0.0-Snapshot by old Tigase 5.2.3 configuration files that was created by the installer.

after then, when the pubsub was enabled, I had no problem. but when I omit this component from my component list in the init file,

my log files become really big and all tigase.log.0 to tigase.log.4 was created and cpu usage stuck at +50%. so I assumed that server

stuck in an infinite loop. I checked the log file, and something odd was that there was some packets was routed to pubsub@domain.com and there wasn't any!

(1)

Added by Wojciech Kapcia TigaseTeam over 4 years ago

Behnam Hatami wrote:

stuck in an infinite loop. I checked the log file, and something odd was that there was some packets was routed to pubsub@domain.com and there wasn't any!

Could you share a snippet of the logs with the offending packets/entries? Do you have pubsub@domain.com in your roster?

(1)

Added by Behnam Hatami over 4 years ago

Well I Attached my init.properties and log before trying to online admin with PSI and after trying to log in (there tigase.log.0 ... tigase.log.4).

(1)

Added by Wojciech Kapcia TigaseTeam over 4 years ago

Could you try disabling pep plugin in --sm-plugins by prefixing it with - instead of @+@?

(1)

Added by Behnam Hatami over 4 years ago

I tried your suggestion. It worked.

Thanks so much.

    (1-6/6)