Project

General

Profile

How to test the item being published to a node is being received by a client.

Abhinav Gupta
Added over 3 years ago

Hi Everyone,

I was able to configure the pubsub and web ui but when i tried to create a node, it created successfully.

I was able to publish the entry from the webui and it said operation successful but i never recieved any nnotification to any client which is been subscribed to the particular node..

I have to move to this particular mode because in your doc it is written that the publishitem script will not work properly with tclmt.sh file.

I wanted to test that using the rest api calls for the tigase pubsub.

Can someone tell me what wrong with the configurations of the pubsub and rest api in my init file, and kindly let me know what am i doing wrong.

Please let me know how to fix it.

Also please let me know how will i test whether the pubsub notifications is been sent to the particular user subscribed will get the notification.

I am publishing the data from the admin interface (web based) and clients are running on pidgin and conversejs (one in pidgin and other in conversejs)

How will i test whether the information published on the node is been recieved.

Also in the webui, when i tried to subscribe for a node through the webui the text field for jid is not present and no submit or confirm button. Also the node created by tclmt is not visible to web ui and vice versa is also true.

Also can please anyone help me understand why the node created by tclmt is visible to tclmt only not to the webui and vice versa.

Please help me out guys.

Any advice/suggestions will be highly appreciated.

Thanks and Regards,

Abhinav


Replies (1)

Added by Wojciech Kapcia TigaseTeam over 3 years ago

https://projects.tigase.org/projects/tigase-pubsub/wiki/REST_API:

Tigase PubSub Component REST API requires Tigase HTTP API Component to be properly installed and configured and requires that all Tigase PubSub Component ad-hoc scripts are deployed as well. It is also required that jid of Tigase HTTP API Component is added to list of service admin jids to allow execution of ad-hoc commands.

in your init.properties you've added pubsub component and not HTTP API component.

    (1-1/1)