Project

General

Profile

Bug #1194

Avatar?id=6023&size=22x22

S2S Dialback issue

Added by Andrzej Wójcik Tigase team member about 5 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
2013-04-10
Due date:
% Done:

0%

Estimated time:
Database:
n/a
Applicable version:
5.2.0-master
Source Code Disclaimer:
Additional charges approved:
No

Description

Occasionally Tigase XMPP Server is unable to establish S2S communication with other XMPP servers due to issue with dialback - it returns error:

Remote server not found.
A remote server or service specified as part or all of the JID of the intended recipient does not exist.
S2S - destination host not found

Remote server usually reports it as connection timeout or that it is not able to find dialback key, what forces remote server to fail during dialback.

s2s_dialback_issue (213 KB) s2s_dialback_issue Part of log which shows issue Andrzej Wójcik, 2013-04-10 10:20 PM
s2s_dialback_issue_extracted (1.33 KB) s2s_dialback_issue_extracted Extracted values of dialback communication over s2s Andrzej Wójcik, 2013-04-10 10:20 PM

History

#1 Avatar?id=6023&size=24x24 Updated by Artur Hefczyc Tigase team member almost 5 years ago

  • Assignee set to Andrzej Wójcik
  • Target version set to tigase-server-5.2.1
  • Applicable version set to 5.2.0-master-branch
  • Version set to tigase-server-5.2.0

#2 Avatar?id=6023&size=24x24 Updated by Artur Hefczyc Tigase team member about 4 years ago

  • Target version changed from tigase-server-5.2.1 to tigase-server-7.0.0
  • Applicable version changed from 5.2.0-master-branch to 5.2.0-master

#3 Avatar?id=6023&size=24x24 Updated by Artur Hefczyc Tigase team member about 4 years ago

  • Target version changed from tigase-server-7.0.0 to tigase-server-5.2.1

#4 Updated by Andrzej Wójcik Tigase team member about 4 years ago

  • Status changed from New to In Progress

#5 Updated by Andrzej Wójcik Tigase team member about 4 years ago

  • Status changed from In Progress to In QA
  • Assignee changed from Andrzej Wójcik to Artur Hefczyc

It looks like this issue was caused by a few things:

  1. Tigase.IM was running version of Tigase XMPP Server in which it was possible to overload S2S connection establishing thread, which would lead to sending dialback request after another dialback request was sent with new secret.

  2. Tigase XMPP Server established more than 1 connection to remove server (as remote server was a cluster - tigase.im) and each node received different secret for authentication which could lead some connections to fail as Tigase XMPP Server was keeping only last generated secret as valid.

Currently some things changed:

  1. Tigase XMPP Server is using multiple threads for DNS resolution, so such overload is not possible now.

  2. Since S2S now implements XEP-0185 (see #980) each generated secret sent to remote server will be validated (not only last one)

#6 Avatar?id=6023&size=24x24 Updated by Artur Hefczyc Tigase team member about 4 years ago

  • Status changed from In QA to Closed
  • Target version changed from tigase-server-5.2.1 to tigase-server-7.0.0

Good work, thank you.

I guess the fix is in the master report branch, so it will be included in the 5.3.0?

Also available in: Atom PDF