Project

General

Profile

Bug #4124

Jaxmpp library fails to support see-other-host

Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
Start date:
2016-04-25
Due date:
% Done:

100%

Estimated time:
Source Code Disclaimer:

Description

Jaxmpp library fails to support see-other-host on WebSocket connection in GWT version.

In fact it opens more than one connector in same time which results in mixed event and state of Jaxmpp as single Jaxmpp instance receives events from many connectors.


Related issues

Related to Tigase JaXMPP Client Library - Task #4125: Improve handling of changed instances by JaxmppNew2016-04-25

Associated revisions

Revision 782bab91 (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 2 years ago

Bug #4124 - fixed issue with support for see-other-host with WebSocket in GWT version

Revision 20104ca7 (diff)
Added by Andrzej Wójcik IoT 1 CloudTigaseTeam over 2 years ago

Bug #4124 - fixed issue with support for see-other-host with WebSocket in GWT version

History

#1 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 2 years ago

  • Related to Task #4125: Improve handling of changed instances by Jaxmpp added

#2 Updated by Andrzej Wójcik IoT 1 CloudTigaseTeam over 2 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

I found cause of this issue - events were still generated and delivered from replaced instance of WebSocketConnector to Jaxmpp which already had new instance of WebSocketConnector.

This is most likely caused by processing changes introduced recently, however I think this may be solved on library level by changes to how Jaxmpp releases/unregisters old instances of classes. For that I created separate task #4125

Also available in: Atom PDF